Agilent MLC crashing on addition of device

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

Agilent MLC crashing on addition of device

Jeff Spector
Greetings,
  I'm trying to set up an MLC400B Agilent laser combiner in mm 2.0 gamma on a windows 10 machine. The combiner worked on our old win 7 machine but it has since been retired. Everything seemed to be going smoothly. I can control the combiner with LCcontrol64, but when I try to add the device in device manager, micromanager just quits and all windows close with no error message. Can someone please help?
Thanks,
 -Jeff



_______________________________________________
micro-manager-general mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/micro-manager-general
Reply | Threaded
Open this post in threaded view
|

Re: Agilent MLC crashing on addition of device

Nico Stuurman-2
Hi Jeff,

> I'm trying to set up an MLC400B Agilent laser combiner in mm 2.0 gamma
> on a windows 10 machine. The combiner worked on our old win 7 machine
> but it has since been retired. Everything seemed to be going smoothly.
> I can control the combiner with LCcontrol64, but when I try to add the
> device in device manager, micromanager just quits and all windows
> close with no error message. Can someone please help?

Did you copy the LaserCombinerSDK DLL into the micro-manager directory? 
If so, then the crash suggests a version mismatch between that DLL and
the version that the micro-manager code was build against.  I can look
into this more on Monday, but in the mean time it will be good to check
the version of LCControl64 that you are running.

Best,


Nico



_______________________________________________
micro-manager-general mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/micro-manager-general