Quantcast

Andor Zyla 4.2 10-tap loses connection after computer sleeps

classic Classic list List threaded Threaded
5 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Andor Zyla 4.2 10-tap loses connection after computer sleeps

MarshallC
Hello everyone,
I had this camera running fine on our old workstation, however the RAID on that system started acting up, so I built a new workstation.  After installing and updating uManager and the SDK I was up and running again, however if the computer sleeps uManager won't connect to the camera again.  I've tried putting the system to sleep with camera power off/on and waking with off/on (all 4 combos) and it happens regardless.  Also, I've had no problems connecting and running the camera with Solis after waking.  I was running a nightly build 20170217, and just updated to 20170228 in hopes that it was a quirk with that particular build.  Also, I've done all the usual (link-state power management disabled, C-states disabled, checked and updated bitflow drivers, etc.).  I'm at a loss for what could be causing this, and it seems to be isolated to uManager, although it could be something else that I overlooked.

On another note, the new system has a Samsung 960 Pro 1TB nvme drive that actually hits 2+ GB/s sequential write right out of the box.  Given the price point compared to a SSD RAID and controller I highly recommend this route.  I added a 16 TB HDD RAID using the built-in raid controller to offload data during a long imaging session and the combo so far has been ideal for this camera and could probably handle 2 just fine.

Thanks for the help,
Marshall
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Andor Zyla 4.2 10-tap loses connection after computer sleeps

Nico Stuurman-2
Hi Marshall,


> I had this camera running fine on our old workstation, however the RAID on
> that system started acting up, so I built a new workstation.  After
> installing and updating uManager and the SDK I was up and running again,
> however if the computer sleeps uManager won't connect to the camera again.

So, anytime after the computer sleeps you have to restart it to get
Micro-Manager to work with the camera again?  Is this on Windows 10?  
Hope that Andor has some ideas about what may be going on.

> I've tried putting the system to sleep with camera power off/on and waking
> with off/on (all 4 combos) and it happens regardless.  Also, I've had no
> problems connecting and running the camera with Solis after waking.
Is Solis using the same version of the Andor SDK?
> On another note, the new system has a Samsung 960 Pro 1TB nvme drive that
> actually hits 2+ GB/s sequential write right out of the box.  Given the
> price point compared to a SSD RAID and controller I highly recommend this
> route.  I added a 16 TB HDD RAID using the built-in raid controller to
> offload data during a long imaging session and the combo so far has been
> ideal for this camera and could probably handle 2 just fine.

That sounds awesome!  Thanks for sharing!

Best,

Nico


------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, SlashDot.org! http://sdm.link/slashdot
_______________________________________________
micro-manager-general mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/micro-manager-general
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Andor Zyla 4.2 10-tap loses connection after computer sleeps

Matthew Milford
Hi Folks,

The Bitflow card does not resume from sleep properly.  Therefore we don't support this functionality and recommend disabling sleep in the Zyla Quick-Start guide.  

However, it's interesting that it seems to work in Solis.  Are you sure this is repeatable and not just a fluke?  I will ask Bitflow if this has been fixed in newer versions of the software.  

Regards,
Matthew
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Andor Zyla 4.2 10-tap loses connection after computer sleeps

MarshallC
In reply to this post by Nico Stuurman-2
Nico Stuurman-2 wrote
So, anytime after the computer sleeps you have to restart it to get
Micro-Manager to work with the camera again?  
Yes, if the computer sleeps or hibernates the camera won't connect again on wake.
To get around this I've just disabled sleep and hibernate and do a full shutdown when it won't be used for an extended period.

Nico Stuurman-2 wrote
Is this on Windows 10?  
Hope that Andor has some ideas about what may be going on.
No, I'm running Win7.  It sounds like Andor knows about this.  FYI I'm running Solis V4.27.30001.0 SDK V2.99.33001.0 and uManager 1.4.23 20170228 SDK V3.13.30001.0.

As far as being able to reproduce the problem I was mistaken about Solis.  When I tried it a couple times this morning it can't reconnect either.  Not sure why I thought it had before, I was probably mistaking the monitor shutting off for full sleep.  Sorry about the confusion.
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Andor Zyla 4.2 10-tap loses connection after computer sleeps

Matthew Milford
MarshallC wrote
As far as being able to reproduce the problem I was mistaken about Solis.  When I tried it a couple times this morning it can't reconnect either.  Not sure why I thought it had before, I was probably mistaking the monitor shutting off for full sleep.  Sorry about the confusion.
Wondered how it could be specific to Micro-manager and not to Solis!  They're both using the same drivers.  

Bitflow have confirmed that resume from sleep in Windows 7 is not supported by the Bitflow SDK, which is why we recommend disabling this.  
Loading...