Autofocus offset problem

classic Classic list List threaded Threaded
6 messages Options
Reply | Threaded
Open this post in threaded view
|

Autofocus offset problem

Sinan Can
Hi, 

We have Nikon Ti Eclipse with Perfect Focus System and  Nikon 100x 1,49 oil objective. The perfect focus system is not functioning properly with the Micromanager. We can move the objective up/down using TIZdrive, and it works fine. Once we lock the PFS, when we need fine adjustment of the z position, so whenever we try to offset it, for the first step of up/down it moves, and then it unlocks from the PFS and I am getting the following error: 

Cannot get value of property "Status: [ Error in device "TIPFSStatus" : PFS reported invalid status (0) (25003)]

Any suggestions how to fix this?

Thanks a lot, 


_______________________________________________
micro-manager-general mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/micro-manager-general
Reply | Threaded
Open this post in threaded view
|

Re: Autofocus offset problem

nanthony
Hi Sinan,

I use often PFS while using Micromanager but I don't usually control pfs
from micromanger. I simply manually adjust the focus, enable pfs, and then
run my experiment from micromanager without tweaking pfs and it works fine.

I'm not sure if I understand exactly what you are doing that is causing this
error, but if you write out a clear procedure that I can follow I will test
it out on my system and see what happens.

--Nick



--
Sent from: http://micro-manager.3463995.n2.nabble.com/


_______________________________________________
micro-manager-general mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/micro-manager-general
Reply | Threaded
Open this post in threaded view
|

Re: Autofocus offset problem

Stuurman, Nico
In reply to this post by Sinan Can
Hi Sinan,

> We have Nikon Ti Eclipse with Perfect Focus System and  Nikon 100x
> 1,49 oil objective. The perfect focus system is not functioning
> properly with the Micromanager. We can move the objective up/down
> using TIZdrive, and it works fine. Once we lock the PFS, when we need
> fine adjustment of the z position, so whenever we try to offset it,
> for the first step of up/down it moves, and then it unlocks from the PFS.

Whenever the PFS is locked, any change in the Z-Drive itself will unlock
the PFS (this is done by the firmware of the microscope itself, and
there is a lot of code in MM dealing with this "issue").  So, you should
avoid changing the Z-Drive directly, but rather change the PFS offset to
change the focus.  Your microscope has a remote dial that does exactly
this.  If you want to change the PFS offset from Micro-Manager using the
Stage Control window (or anything else), make sure that you select the
PFS offset rather than the Z-drive.  Changing the PFS offset while the
PFS is locked will do exactly what you want.

Best,

Nico



_______________________________________________
micro-manager-general mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/micro-manager-general
Reply | Threaded
Open this post in threaded view
|

Re: Autofocus offset problem

Sinan Can
Dear Nico,

When the PFS is locked, the offsetting wheel is not functioning whenever we run the micromanager. When I tried to change on Micromanager, only allows me to take a single step up or down, nothing more. I think the PPS offset on micromanager does not read the z-position correctly since the z-position reading is for Z-drive vs PPS offset is different. Any suggestions/ideas why this is happening? 

Thanks a lot, 



On Thu, Nov 22, 2018 at 10:56 AM Stuurman, Nico <[hidden email]> wrote:
Hi Sinan,

> We have Nikon Ti Eclipse with Perfect Focus System and  Nikon 100x
> 1,49 oil objective. The perfect focus system is not functioning
> properly with the Micromanager. We can move the objective up/down
> using TIZdrive, and it works fine. Once we lock the PFS, when we need
> fine adjustment of the z position, so whenever we try to offset it,
> for the first step of up/down it moves, and then it unlocks from the PFS.

Whenever the PFS is locked, any change in the Z-Drive itself will unlock
the PFS (this is done by the firmware of the microscope itself, and
there is a lot of code in MM dealing with this "issue").  So, you should
avoid changing the Z-Drive directly, but rather change the PFS offset to
change the focus.  Your microscope has a remote dial that does exactly
this.  If you want to change the PFS offset from Micro-Manager using the
Stage Control window (or anything else), make sure that you select the
PFS offset rather than the Z-drive.  Changing the PFS offset while the
PFS is locked will do exactly what you want.

Best,

Nico



_______________________________________________
micro-manager-general mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/micro-manager-general


_______________________________________________
micro-manager-general mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/micro-manager-general
Reply | Threaded
Open this post in threaded view
|

Re: Autofocus offset problem

nanthony
Sinan Can wrote
> When the PFS is locked, the offsetting wheel is not functioning whenever
> we
> run the micromanager. When I tried to change on Micromanager, only allows
> me to take a single step up or down, nothing more. I think the PPS
> offset on micromanager does not read the z-position correctly since the
> z-position reading is for Z-drive vs PPS offset is different.
> Any suggestions/ideas why this is happening?

Hi Sinan,

Try going in to the device property browser and setting `Core-Focus` to
`PFSOffset`. This should cause micromanager to use the pfs offset instead of
the z-drive position.

I'm not sure why your manual control wheel wouldn't be working though.

--Nick



--
Sent from: http://micro-manager.3463995.n2.nabble.com/


_______________________________________________
micro-manager-general mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/micro-manager-general
Reply | Threaded
Open this post in threaded view
|

Re: Autofocus offset problem

Stuurman, Nico
On 11/26/18 9:22 AM, nanthony wrote:

> Sinan Can wrote
>> When the PFS is locked, the offsetting wheel is not functioning whenever
>> we
>> run the micromanager. When I tried to change on Micromanager, only allows
>> me to take a single step up or down, nothing more. I think the PPS
>> offset on micromanager does not read the z-position correctly since the
>> z-position reading is for Z-drive vs PPS offset is different.
>> Any suggestions/ideas why this is happening?
> Hi Sinan,
>
> Try going in to the device property browser and setting `Core-Focus` to
> `PFSOffset`. This should cause micromanager to use the pfs offset instead of
> the z-drive position.
>
> I'm not sure why your manual control wheel wouldn't be working though.

That is very strange indeed.  To be sure Sinan, does the wheel work with
the PFS locked and Micro-Manager not running?  Then when you start
Micro-Manager it stops working?

Best,

Nico



_______________________________________________
micro-manager-general mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/micro-manager-general