Axio observer z position

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Axio observer z position

tsuchyna
I have setup micromanager with an Axio-Observer Z1 through a serial
connection and have just started testing it. Everything was working fine
- it appears I have control over most motorized scope functions and have
been able to acquire images using the "acquire" and "snap" buttons.

The difficulty arises when I tried to Multi-D Acq. I was simply trying
to acquire a 20 slice z-stack in transmitted light mode. The "Slices
(Z)" panel does not obtain the start and end z positions from the
microscope when I press the set buttons and am in absolute Z mode. I
tried moving the focus manually to different positions, but only zeros
appear in Z-start and Z-end spots when I press set.

When I use relative Z mode I can input the Z-start and Z-end manually,
but when I press acquire the software acquires 20 images from the same
z-position even though the "summary panel" says "number of slices: 20".

The focus changes when I type a new value into the configuration
settings for z-drive focus motor and displays the correct position when
I change the focus manually and press refresh on the main window. So I
know it can read the position and has control of the z-drive motor. The
problem occurs in the Multi-D Acq. window.

Any suggestions?

Thanks

Tom

--
Thomas M. Suchyna, Ph.D.
Dept. of Physiology and Biophysics
301 Cary Hall
SUNY at Buffalo
Buffalo, NY 14214
Phone: 716-829-5156
e-mail: [hidden email]



------------------------------------------------------------------------------
Download Intel® Parallel Studio Eval
Try the new software tools for yourself. Speed compiling, find bugs
proactively, and fine-tune applications for parallel performance.
See why Intel Parallel Studio got high marks during beta.
http://p.sf.net/sfu/intel-sw-dev
_______________________________________________
micro-manager-general mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/micro-manager-general
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Axio observer z position

Nico Stuurman-4
Hi Thomas,

> I have setup micromanager with an Axio-Observer Z1 through a serial
> connection and have just started testing it.
> The difficulty arises when I tried to Multi-D Acq. I was simply trying
> to acquire a 20 slice z-stack in transmitted light mode. The "Slices
> (Z)" panel does not obtain the start and end z positions from the
> microscope when I press the set buttons and am in absolute Z mode. I
> tried moving the focus manually to different positions, but only zeros
> appear in Z-start and Z-end spots when I press set.

Can you send the Corelog.txt in debug mode and your configuration file  
to [hidden email] (see the FAQ with detailed instructions on  
how to get these files)?

Best,

Nico



------------------------------------------------------------------------------
Download Intel® Parallel Studio Eval
Try the new software tools for yourself. Speed compiling, find bugs
proactively, and fine-tune applications for parallel performance.
See why Intel Parallel Studio got high marks during beta.
http://p.sf.net/sfu/intel-sw-dev
_______________________________________________
micro-manager-general mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/micro-manager-general
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Axio observer z position

Nico Stuurman-4
In reply to this post by tsuchyna
For others experiencing the same problem:

> The difficulty arises when I tried to Multi-D Acq.  The "Slices
> (Z)" panel does not obtain the start and end z positions from the
> microscope when I press the set buttons and am in absolute Z mode. I
> tried moving the focus manually to different positions, but only zeros
> appear in Z-start and Z-end spots when I press set.
>
> When I use relative Z mode I can input the Z-start and Z-end manually,
> but when I press acquire the software acquires 20 images from the same
> z-position even though the "summary panel" says "number of slices:  
> 20".

This was solved by setting the focus drive of the microscope as the  
"default focus stage" in Step 5 of the Hardware Conifguration Wizard.

Best,

Nico



------------------------------------------------------------------------------
Download Intel® Parallel Studio Eval
Try the new software tools for yourself. Speed compiling, find bugs
proactively, and fine-tune applications for parallel performance.
See why Intel Parallel Studio got high marks during beta.
http://p.sf.net/sfu/intel-sw-dev
_______________________________________________
micro-manager-general mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/micro-manager-general
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Axio observer z position

nmankenbruck
In reply to this post by tsuchyna
I am having a similar issue with our Zeiss AxioObserver Z1 microscope. I came across this post and tried to troubleshoot by setting the z-drive to be the default as recommended, but the problem still persists. I am running a more recent version of the software (1.4.22). Is there a more current update on how to resolve this issue?
Loading...