Configuring Ti2 through Micro-Manager

classic Classic list List threaded Threaded
6 messages Options
Reply | Threaded
Open this post in threaded view
|

Configuring Ti2 through Micro-Manager

Nick Galati

Hello Everyone


I am having trouble operating a Nikon Ti2 through Micro-Manager. I am able to communicate with the Ti2 through the Nikon control software. However, after I copied the Ti2_Mic_Driver.dll into the Micro-Manager directory, the Ti2 is still showing up as "unavailable" in the Micro-Manager hardware configuration wizard.


Has anyone else run into this issue?


Thanks in advance,


Nick



_______________________________________________
micro-manager-general mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/micro-manager-general
Reply | Threaded
Open this post in threaded view
|

Re: Configuring Ti2 through Micro-Manager

oftakofta
Hi Nick!

Yes, I'm having the same issue if I use the MM2-gamma branch. The immediate solution is to use either the 1.4 or the 2.0-beta branches, then you don't do anything about it until someone reminds you about it :). There seems to be some type of silent device driver error that causes the Ti2_Mic_Driver.dll to not load properly in the MM2.0-gamma branch. I haven't had too much time to investigate due to heavy microscope usage.

Peace

Dr. Jens Eriksson, manager

Sellin Imaging Platform

Dep. Medical Biohecmistry and Microbiology

Uppsala University

Sweden


On Thu, Apr 25, 2019 at 9:38 AM Nick Galati <[hidden email]> wrote:

Hello Everyone


I am having trouble operating a Nikon Ti2 through Micro-Manager. I am able to communicate with the Ti2 through the Nikon control software. However, after I copied the Ti2_Mic_Driver.dll into the Micro-Manager directory, the Ti2 is still showing up as "unavailable" in the Micro-Manager hardware configuration wizard.


Has anyone else run into this issue?


Thanks in advance,


Nick

_______________________________________________
micro-manager-general mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/micro-manager-general


--
Science is built up of facts, as a house is built of stones; but an accumulation of facts is no more a science than a heap of stones is a house.  /Henri Poincaré


_______________________________________________
micro-manager-general mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/micro-manager-general
Reply | Threaded
Open this post in threaded view
|

Re: Configuring Ti2 through Micro-Manager

nathalieqbb@gmail.com
We are using the nightly built 1.4.23 20180720 and it works fine with the Ti2.
Nathalie

On Thu, Apr 25, 2019 at 10:58 AM Jens Eriksson <[hidden email]> wrote:
Hi Nick!

Yes, I'm having the same issue if I use the MM2-gamma branch. The immediate solution is to use either the 1.4 or the 2.0-beta branches, then you don't do anything about it until someone reminds you about it :). There seems to be some type of silent device driver error that causes the Ti2_Mic_Driver.dll to not load properly in the MM2.0-gamma branch. I haven't had too much time to investigate due to heavy microscope usage.

Peace

Dr. Jens Eriksson, manager

Sellin Imaging Platform

Dep. Medical Biohecmistry and Microbiology

Uppsala University

Sweden


On Thu, Apr 25, 2019 at 9:38 AM Nick Galati <[hidden email]> wrote:

Hello Everyone


I am having trouble operating a Nikon Ti2 through Micro-Manager. I am able to communicate with the Ti2 through the Nikon control software. However, after I copied the Ti2_Mic_Driver.dll into the Micro-Manager directory, the Ti2 is still showing up as "unavailable" in the Micro-Manager hardware configuration wizard.


Has anyone else run into this issue?


Thanks in advance,


Nick

_______________________________________________
micro-manager-general mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/micro-manager-general


--
Science is built up of facts, as a house is built of stones; but an accumulation of facts is no more a science than a heap of stones is a house.  /Henri Poincaré
_______________________________________________
micro-manager-general mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/micro-manager-general


_______________________________________________
micro-manager-general mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/micro-manager-general
Reply | Threaded
Open this post in threaded view
|

Re: Configuring Ti2 through Micro-Manager

Nick Galati

Thank you Jens and Nathalie,


I've gone back to the 1.4.23 20180720 build and the Ti2 still shows up as unavailable on my machine. Could this be related to an operating system issue? 


Nikon states that Windows 10 Pro and a 128 MB video memory are system requirements for running the Nikon Control Software. However, I'm currently trying to get things set up on a Windows 10 Enterprise machine that doesn't have a graphics card (I'm doing this because my more powerful workstation is being used for something else at the moment). 


Since I can communicate with the Ti2 via the control software on the Windows 10 Enterprise machine that lacks a video card, I assumed the minimum requirements weren't going to be a problem with Micro-manager. 


I'll switch computers and let you know if this fixes the problem.


Thanks,


Nick


From: Nathalie Qb <[hidden email]>
Sent: Thursday, April 25, 2019 1:11:06 AM
To: Micro-Manager General
Subject: Re: [micro-manager-general] Configuring Ti2 through Micro-Manager
 
We are using the nightly built 1.4.23 20180720 and it works fine with the Ti2.
Nathalie

On Thu, Apr 25, 2019 at 10:58 AM Jens Eriksson <[hidden email]> wrote:
Hi Nick!

Yes, I'm having the same issue if I use the MM2-gamma branch. The immediate solution is to use either the 1.4 or the 2.0-beta branches, then you don't do anything about it until someone reminds you about it :). There seems to be some type of silent device driver error that causes the Ti2_Mic_Driver.dll to not load properly in the MM2.0-gamma branch. I haven't had too much time to investigate due to heavy microscope usage.

Peace

Dr. Jens Eriksson, manager

Sellin Imaging Platform

Dep. Medical Biohecmistry and Microbiology

Uppsala University

Sweden


On Thu, Apr 25, 2019 at 9:38 AM Nick Galati <[hidden email]> wrote:

Hello Everyone


I am having trouble operating a Nikon Ti2 through Micro-Manager. I am able to communicate with the Ti2 through the Nikon control software. However, after I copied the Ti2_Mic_Driver.dll into the Micro-Manager directory, the Ti2 is still showing up as "unavailable" in the Micro-Manager hardware configuration wizard.


Has anyone else run into this issue?


Thanks in advance,


Nick

_______________________________________________
micro-manager-general mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/micro-manager-general


--
Science is built up of facts, as a house is built of stones; but an accumulation of facts is no more a science than a heap of stones is a house.  /Henri Poincaré
_______________________________________________
micro-manager-general mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/micro-manager-general


_______________________________________________
micro-manager-general mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/micro-manager-general
Reply | Threaded
Open this post in threaded view
|

Re: Configuring Ti2 through Micro-Manager

Nick Galati

Just to update folks on the issue...


Off-thread Nico suggested to go back to an earlier version of the Nikon Ti2 Control Software. So I went back to Nikon Ti2 Control for Windows Ver. 1.1.0 build 48 (from July 2017). Now I am able to configure the Ti2 in Micro-Manager 2.0.0 Beta 20180926.


So I guess that the newest version of Nikon Ti2 Control Ver. 2.1.0  does not play nicely with Micro-Manager.


Issue resolved and thank you for the help.


Nick


From: Nick Galati <[hidden email]>
Sent: Thursday, April 25, 2019 9:06:47 AM
To: Micro-Manager General
Subject: Re: [micro-manager-general] Configuring Ti2 through Micro-Manager
 

Thank you Jens and Nathalie,


I've gone back to the 1.4.23 20180720 build and the Ti2 still shows up as unavailable on my machine. Could this be related to an operating system issue? 


Nikon states that Windows 10 Pro and a 128 MB video memory are system requirements for running the Nikon Control Software. However, I'm currently trying to get things set up on a Windows 10 Enterprise machine that doesn't have a graphics card (I'm doing this because my more powerful workstation is being used for something else at the moment). 


Since I can communicate with the Ti2 via the control software on the Windows 10 Enterprise machine that lacks a video card, I assumed the minimum requirements weren't going to be a problem with Micro-manager. 


I'll switch computers and let you know if this fixes the problem.


Thanks,


Nick


From: Nathalie Qb <[hidden email]>
Sent: Thursday, April 25, 2019 1:11:06 AM
To: Micro-Manager General
Subject: Re: [micro-manager-general] Configuring Ti2 through Micro-Manager
 
We are using the nightly built 1.4.23 20180720 and it works fine with the Ti2.
Nathalie

On Thu, Apr 25, 2019 at 10:58 AM Jens Eriksson <[hidden email]> wrote:
Hi Nick!

Yes, I'm having the same issue if I use the MM2-gamma branch. The immediate solution is to use either the 1.4 or the 2.0-beta branches, then you don't do anything about it until someone reminds you about it :). There seems to be some type of silent device driver error that causes the Ti2_Mic_Driver.dll to not load properly in the MM2.0-gamma branch. I haven't had too much time to investigate due to heavy microscope usage.

Peace

Dr. Jens Eriksson, manager

Sellin Imaging Platform

Dep. Medical Biohecmistry and Microbiology

Uppsala University

Sweden


On Thu, Apr 25, 2019 at 9:38 AM Nick Galati <[hidden email]> wrote:

Hello Everyone


I am having trouble operating a Nikon Ti2 through Micro-Manager. I am able to communicate with the Ti2 through the Nikon control software. However, after I copied the Ti2_Mic_Driver.dll into the Micro-Manager directory, the Ti2 is still showing up as "unavailable" in the Micro-Manager hardware configuration wizard.


Has anyone else run into this issue?


Thanks in advance,


Nick

_______________________________________________
micro-manager-general mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/micro-manager-general


--
Science is built up of facts, as a house is built of stones; but an accumulation of facts is no more a science than a heap of stones is a house.  /Henri Poincaré
_______________________________________________
micro-manager-general mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/micro-manager-general


_______________________________________________
micro-manager-general mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/micro-manager-general
Reply | Threaded
Open this post in threaded view
|

Re: Configuring Ti2 through Micro-Manager

Stuurman, Nico
In reply to this post by oftakofta
On 4/25/19 12:56 AM, Jens Eriksson wrote:
> Yes, I'm having the same issue if I use the MM2-gamma branch. The
> immediate solution is to use either the 1.4 or the 2.0-beta branches,
> then you don't do anything about it until someone reminds you about it
> :). There seems to be some type of silent device driver error that
> causes the Ti2_Mic_Driver.dll to not load properly in the MM2.0-gamma
> branch. I haven't had too much time to investigate due to heavy
> microscope usage.

2.0-gamma and 1.4 use the exact same hardware interface code, so there
is no logic behind your observation (other than that you may be
comparing builds from different dates).  2.0-beta is frozen in time (so
basically behind the others as far as hardware interface goes).

Best,


Nico


_______________________________________________
micro-manager-general mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/micro-manager-general