Corvus controller

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Corvus controller

haguy.wolfenson
This post has NOT been accepted by the mailing list yet.
Hello,
I am trying to set up an old Leica dmire2 microscope with MM.
I was able to install all of the components, except from the Corvus high resolution positioning controller which is used to control the XY stage.
I tried to add the ‘ITK Corvus Controller’ in the wizard but kept getting the same message - is the device connected to the port? (14). I tried using 115200 Baude rate as suggested on the MM website but it didn’t work either. I am running this on Windows 7, 32 bit.
Any advice would be greatly appreciated.
Thanks,
Haguy.


----
Haguy Wolfenson, Assistant Professor
Department of Genetics and Developmental Biology
Rappaport Faculty of Medicine, Technion – Israel Institute of Technology
1 Efron St., Haifa 31096, Israel
Tel: +972-4-829-5333; +972-52-212-3595
Lab website: http://wolfenson.net.technion.ac.il/

Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Corvus controller

Gryphon
Hello Haguy,

Is the controller seen in Device manager? If yes, which port does it use? Can you use it with some other program, i.e. the one that is originally shipped with controller or the scope?

As long as I remember the controllers manual, it has a short programming overview. Please see "Setting-up operation of the RS-232 connection" in the manual. You can also use something like PuTTy or any other COM r/w program.

Common issues:
- COM port is dead. Check it with another device
- You use USB-to-serial adapter. Throw it away and buy PCI board with COM ports.

I see these specific variants:
- the controller is not seen in Device manager. "Check signal cable connection", sorry. If you do not use original cable, check wiring. It is described in "Connectors" section
- the controller is seen, but you cannot connect to it anyhow. Check DIP switches, please notice that there is inverting switch
- the controller is seen, you can connect to it, but baud rate does not match you thought it ought to be. Check DIP switches.
- the controller is seen, you can operate it using Hyperterminal, baudrate matches your expectations, you cannot use it in MM. If port number is in range 0-9, and you still have problems, something really strange happened. If outside the range, change COM port to match the range.

Best,
Sergey
Loading...