GenericSLM Projector Plugin

classic Classic list List threaded Threaded
5 messages Options
Reply | Threaded
Open this post in threaded view
|

GenericSLM Projector Plugin

mglotzer
Hi All,

I am working on using the GenericSLM and the projector plugin to perform
targeted illumination. So far, things are looking good - MM controls the
projector, calibrations work fine, etc.

One problem I am having is that the system does not appear to respond to the
values I set for Exposure Time or Delay Time in the Projector plugin window.
No matter what they are set at, the appropriate shutter opens and closes
briefly ~50 msec. I would like to be able to control the exposure time.

If I use the projector as a channel in MDA, I can set the exposure to any
value.

Does anyone have any idea how to change the exposure time for the targeted
illumination? I note that the dialog boxes and terminology differ somewhat
from those found on this  page <https://micro-manager.org/wiki/Projector>  .

I would also like to be able to adjust the intensity of the projector, in
case anyone is familiar with that too.

I am using V 1.4.

Thank you for the assistance.
Michael



--
Sent from: http://micro-manager.3463995.n2.nabble.com/


_______________________________________________
micro-manager-general mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/micro-manager-general
Reply | Threaded
Open this post in threaded view
|

Re: GenericSLM Projector Plugin

Stuurman, Nico
Hi Michael,

What projector device are you using? Doing the exposure and timing
correctly for all supported devices (DMDs, galvos, etc.. from various
vendors with their own interfaces), turned out to be a nightmare. 
Knowing your specific setup will make it easier to give advice.

Best,

Nico

> Hi All,
>
> I am working on using the GenericSLM and the projector plugin to perform
> targeted illumination. So far, things are looking good - MM controls the
> projector, calibrations work fine, etc.
>
> One problem I am having is that the system does not appear to respond to the
> values I set for Exposure Time or Delay Time in the Projector plugin window.
> No matter what they are set at, the appropriate shutter opens and closes
> briefly ~50 msec. I would like to be able to control the exposure time.
>
> If I use the projector as a channel in MDA, I can set the exposure to any
> value.
>
> Does anyone have any idea how to change the exposure time for the targeted
> illumination? I note that the dialog boxes and terminology differ somewhat
> from those found on this  page <https://protect2.fireeye.com/url?k=4b5e5a29-171e6f17-4b5e7d34-0cc47ad9c120-87225872473de044&u=https://micro-manager.org/wiki/Projector>  .
>
> I would also like to be able to adjust the intensity of the projector, in
> case anyone is familiar with that too.
>
> I am using V 1.4.
>
> Thank you for the assistance.
> Michael
>
>
>
> --
> Sent from: http://micro-manager.3463995.n2.nabble.com/
>
>
> _______________________________________________
> micro-manager-general mailing list
> [hidden email]
> https://lists.sourceforge.net/lists/listinfo/micro-manager-general
> .
>


_______________________________________________
micro-manager-general mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/micro-manager-general
Reply | Threaded
Open this post in threaded view
|

Re: GenericSLM Projector Plugin

mglotzer
The projector device is a lightcrafter 4500 connected via HDMI. It’s
positioned in the epi light path of a Zeiss scope which provides the
shutter.

Most of the functions in the projector plugin and generic SLM driver work
great including calibration and color change. (Though I have not yet figured
out how to control its intensity)

The primary issue at the moment seems to be the shutter which does not stay
open for the duration specified in the projector exposure setting. The
correct shutter is chosen in the projector window and it opens but closes
almost immediately.  (Though the shutter will stay open for the specified
time if it is used as a illumination to acquire an image.
The exposure setting in projector does not alter the projector behavior
either, but I imagine that is the expected behavior as the time is
presumably controlled via the shutter.

Thanks.

Best, Michael





--
Sent from: http://micro-manager.3463995.n2.nabble.com/


_______________________________________________
micro-manager-general mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/micro-manager-general
Reply | Threaded
Open this post in threaded view
|

Re: GenericSLM Projector Plugin

mglotzer
I just realized that the shutter maybe receiving conflicting triggers from
the selected shutter and the projector channel. Haven’t had a chance to test
yet.



--
Sent from: http://micro-manager.3463995.n2.nabble.com/


_______________________________________________
micro-manager-general mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/micro-manager-general
Reply | Threaded
Open this post in threaded view
|

Re: GenericSLM Projector Plugin

mglotzer
Further testing of this did not reveal a shutter conflict.

While I can control the timing of targeted illumination by adding a
"projector" channel in the MDA panel, however, the function to "Run ROIs in
Multi-Dimensional Acquisition" with the projector plug-in would not allow
control over the duration of the photo-activation. It also failed to return
from the photo activation function to perform the next scheduled acquisition
step.

It wasn't intuitive to me, but I  was unable to choose a Phototargeting
Channel in the Projection plugin unless I had already chosen a channel group
in MDA.

I'd be eager to hear if others have been able to use the GenericSLM to
perform targeted illumination with "Run ROIs in Multi-Dimensional
Acquisition".

Thanks
best,
Michael




--
Sent from: http://micro-manager.3463995.n2.nabble.com/


_______________________________________________
micro-manager-general mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/micro-manager-general