HCS generator calibration error - Prior/Oasis controller

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

HCS generator calibration error - Prior/Oasis controller

Darren Thomson

Hello,

 

I’m new to MicroManager and would like to harness its full power to drive high-throughput screening of plates.

There is a problem when I try to use the HCS generator plug in:

 

I set up my well template (24), ‘select’ the 1st well on the GUI, move the stage to the 1st well (At this point the ‘cursor’ and ‘stage’ co-oridinates do not match).

Then I calibrate XY. It reads the correct number from the stage in the UI.

 

However, when I clock move to the first well on the GUI, it moves the stage to the centre of the plate and also moves the stage in the opposite X direction, at ½ the distance it should.

-          So when I click ‘Move’ on well A2 on the GUI, the stage instead moves in the opposite direction (left) and only until ½ the distance between the wells.

-          I have configured the pixel sizes and objectives etc. so it can’t be that.

-          I tried refreshing the UI’s incase the XY values were not being picked up.

The main problem is there seems to be no calibration taking plate.

 

The stage works fine when setting positions manually for 24 wells, but this is not feasible for high-throughput..

 

Any ideas?

I’d really appreciate any help!

 

Many thanks,

 

Dr Darren Thomson | Experimental Officer

Manchester Fungal Infection Group (MFIG)

Tel: (+44) (0)161 306 2457

Email: [hidden email]

Manchester Fungal Infection Group

NUS Gold Award Winners 2016 for Lab Sustainability

 

 


------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, Slashdot.org! http://sdm.link/slashdot
_______________________________________________
micro-manager-general mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/micro-manager-general
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: HCS generator calibration error - Prior/Oasis controller

Nico Stuurman-2

Hi Darren,


On 6/16/2017 9:49 AM, Darren Thomson wrote:
There is a problem when I try to use the HCS generator plug in:

 

I set up my well template (24), ‘select’ the 1st well on the GUI, move the stage to the 1st well (At this point the ‘cursor’ and ‘stage’ co-oridinates do not match).

Then I calibrate XY. It reads the correct number from the stage in the UI.

 

However, when I clock move to the first well on the GUI, it moves the stage to the centre of the plate and also moves the stage in the opposite X direction, at ½ the distance it should.

-          So when I click ‘Move’ on well A2 on the GUI, the stage instead moves in the opposite direction (left) and only until ½ the distance between the wells.

-          I have configured the pixel sizes and objectives etc. so it can’t be that.

-          I tried refreshing the UI’s incase the XY values were not being picked up.

The main problem is there seems to be no calibration taking plate.


MM 1.4 or 2.0?  What stage are you using?

It sounds like your stage (device adapter) does not adhere to the convention in Micro-Manager, and it also sounds like it has a factor of 2 error in its stepsize.  See: https://micro-manager.org/wiki/Coordinates_and_Directionality

Best,

Nico



------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, Slashdot.org! http://sdm.link/slashdot
_______________________________________________
micro-manager-general mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/micro-manager-general
Loading...