Live Image Freezes in 2.0beta with SPOT Camera

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

Live Image Freezes in 2.0beta with SPOT Camera

Cole, Mary Beth
Hello everyone, 

I am a new Micro-Manager user and would be very grateful for any insight on this issue! I have tried many of the solutions found on this mailing list without much success so far.

My lab images large regions of bone tissue (e.g. whole cross-sections) with a manual microscope stage, by manually taking overlapping images and merging them together. I am looking to upgrade our manual stage to a motorized stage to more efficiently acquire these tiled images automatically – ideally, the Olympus BX51 microscope build of the ThorLabs “High-Speed Motorized XY Scanning Stage” seen here: https://www.thorlabs.com/newgrouppage9.cfm?objectgroup_id=5360. I would ideally like to use the Micro-Manager plugin AcquireMultipleRegions to take tiled images of multiple bone tissue sections on a slide. 

I haven’t purchased the stage yet because I want to establish that the software can drive both the stage and our current camera. ThorLabs says that their stage is compatible with Micro-Manager, so I also wanted to see whether Micro-Manager could access our SPOT Idea 3.1 Mp color camera. I know that SPOT cameras are unstable in Micro-Manager (per https://micro-manager.org/wiki/SpotCamera) so I tested all Micro-Manager versions until I found the most recent builds that worked. 

The only builds of Micro-Manager that can access our camera are 1.3.49 (32 bit) and 2.0beta (nightly build for 32 bit). All in-between builds (the 1.4 series) cannot access the camera in Live or Snap, but either show blank images, have unsupported pixel depth, or throw the error “Java (TM) SE Binary has stopped working”. 

Live works in 1.3.49 – it never quits with an error. It does lag – when I move to a new region, or change focus/lamp intensity, there is a delay of about 4 seconds before it displays the new region. However, since I am not viewing any time-sensitive moving cells, this would hopefully not be an issue for tiled image acquisition using an older plugin like Slide Explorer.

Ideally, I would like to use 2.0beta build for a better chance of working with the motorized stage, and to have the most recent functionality. In Live view, an initial image of the slide will display. However, when I move the stage to a new region, the Live image is frozen and does not display the new region. Eventually 2.0beta freezes with error “Java (TM) SE Binary has stopped working”.  No fps are displayed in the Live image, except for a split-second (e.g. 0.7 fps will appear briefly). Running the Sequence Buffer Monitor during the Live image shows it filling up to 100% and then throwing the error ~10 seconds later. 

This does not seem to be an issue with Snap in 2.0beta. I can move to a new region and immediately Snap and it will display that new region. So perhaps if AcquireMultipleRegions is moving and snapping, Live not working will not be a problem. However, I would like Live to work to be able to locate the parameters of the region and make image processing adjustments before acquisition if possible. 

We have an old computer, which may be the source of the problem. It is a Dell OptiPlex 980 running Windows 7 Enterprise 32-bit (6.1, Build 7601) Service Pack 1. It has 8192 MB RAM for Memory and available 3572 MB RAM for available OS Memory. I have updated the drivers for Java (version  8 update 144), SPOT Idea 3.1 Mp color camera and ATI Radeon HD 4550 graphics card (which has legacy drivers since 2013). For the graphics card (not sure if this matters), I have display memory 2036 MB, dedicated memory 505 MB, and shared memory 1531 MB. I have unfortunately hit a dead end working with SPOT camera technical support, as they could only suggest camera drivers that did not work. 

This is what I have tried to fix the problem, based on following other solutions on this mailing list:

  • The log file (attached) shows “java.lang.OutOfMemoryError” and finally “Spot Camera GetImageBuffer fails:  invalid acquistion sequence - waited 10950 ms for image ready”
  • Setting the Core-TimeoutMS above this time (e.g. to 20000 ms) in DevicePropertyBrowser does not fix the problem; it merely waits to the higher threshold and then throws the same error
  • Low memory settings (e.g. 150 MB for both Micro-Manager sequence buffer and ImageJ) merely shorten the length of the Sequence Buffer Monitor (to 1/12) before it throws the error
  • The highest balance of memory settings I have found to work through trial and error (900 MB for Micro-Manager sequence buffer and 600 MB) will lengthen the Sequence Buffer Monitor (to 1/75) before it throws the error
  • Not fixed by unchecking “Save XY positions” in Options
  • Not fixed by placing the camera USB in its own USB bus, or adjusting computer power settings, as shown here: https://micro-manager.org/wiki/Personal_computer_setup

If the issue is our computer memory or graphics card, we do have some limited funds to upgrade our equipment. Our IT support person also said he can re-image the computer to be 64-bit, but prefers not to have to reinstall everything. 

Thank you for reading this email and offering any suggestions!

Sincerely, 
Mary Beth



------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, Slashdot.org! http://sdm.link/slashdot
_______________________________________________
micro-manager-general mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/micro-manager-general

CoreLog20170901T233540_pid4432.txt (37K) Download Attachment