MM Windows 10 & COM ports

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

MM Windows 10 & COM ports

StevenF
Hello Micromanager Community,

Lately i have been having some issues concerning the microscope plateforme i
work on. This problem probably has more to do with windows than Micromanager
itself but i can't seem to find any concrete solution to my problems.

During last months, i have experienced Windows "forgetting" all the COM
ports that are associated to my devices. I will leave Friday with everything
fine, i turn off all the devices of the platform and the turn off the
computer, but upon coming back the next monday, it seems as though windows
has forgotten most of the devices that are connected to the computer. In
order to fix the problem i need to remind each device where the driver is
and enable the "Load VCP" button in the forgotten USB devices. This is
annoying because more often than not it reasigns new COM ports and forces me
to rewrite the config file.

If anybody has had this issue before and fixed it help would be greatly
appreciated.

Thanks,

Steven





--
Sent from: http://micro-manager.3463995.n2.nabble.com/

------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, Slashdot.org! http://sdm.link/slashdot
_______________________________________________
micro-manager-general mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/micro-manager-general
Reply | Threaded
Open this post in threaded view
|

Re: MM Windows 10 & COM ports

AustinBlanco
This happens most often if someone moves USB ports.
I’ve got several (maybe 8 or more?) systems on windows 10 and using COM ports without the issue, so I think this could be:

- an issue with the VCP driver (if you enable/disable is *should* hold onto the com #)
- usb plugs being moved
- an issue with your motherboard USB driver

I’d target the VCP first. 
**Also please confirm under advanced power options that “USB selective suspend” is disabled. 


Austin Blanco
Advanced Research Consulting Corporation






On Apr 23, 2018, at 9:52 AM, StevenF <[hidden email]> wrote:

Hello Micromanager Community,

Lately i have been having some issues concerning the microscope plateforme i
work on. This problem probably has more to do with windows than Micromanager
itself but i can't seem to find any concrete solution to my problems.

During last months, i have experienced Windows "forgetting" all the COM
ports that are associated to my devices. I will leave Friday with everything
fine, i turn off all the devices of the platform and the turn off the
computer, but upon coming back the next monday, it seems as though windows
has forgotten most of the devices that are connected to the computer. In
order to fix the problem i need to remind each device where the driver is
and enable the "Load VCP" button in the forgotten USB devices. This is
annoying because more often than not it reasigns new COM ports and forces me
to rewrite the config file.

If anybody has had this issue before and fixed it help would be greatly
appreciated.

Thanks,

Steven





--
Sent from: http://micro-manager.3463995.n2.nabble.com/

------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, Slashdot.org! http://sdm.link/slashdot
_______________________________________________
micro-manager-general mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/micro-manager-general


------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, Slashdot.org! http://sdm.link/slashdot
_______________________________________________
micro-manager-general mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/micro-manager-general
Reply | Threaded
Open this post in threaded view
|

Re: MM Windows 10 & COM ports

StevenF
Hey Austin thanks for the quick reply!

Well i can confirm that no one is moving the USB plugs so i will investigate
the other possible.

I can confirm that the "USB selective suspend” was enabled, although i have
configure my desktop to never go into sleep so i am not sure this was the
issue! In any case I have disabled it!

I will look into the VCP driver and the motherboard!

Thanks again,

Steven



--
Sent from: http://micro-manager.3463995.n2.nabble.com/

------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, Slashdot.org! http://sdm.link/slashdot
_______________________________________________
micro-manager-general mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/micro-manager-general