MM interface response slowly

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

MM interface response slowly

Udi Binshtok
Hello,

Currently using MM 1.2 gamma1 20190623, and there is a very long time delays (somtimes 10-15 seconds) at the interface after taking actions, such as push live/stop live, turning devices on/off, refresh position status in multiD and more.
The delay is at the interface, that is the devices are responding at real time when pressing any button but the software seems to be stuck for few second (up to 10-15 seconds).

Can you help me figure it out?

I will note that there is no such delay when using the interfaces of each of the devices, it is only MM software that has these delays.

Udi


_______________________________________________
micro-manager-general mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/micro-manager-general
Reply | Threaded
Open this post in threaded view
|

Re: MM interface response slowly

Stuurman, Nico
On 6/27/19 3:43 AM, Udi Binshtok wrote:
> Currently using MM 1.2 gamma1 20190623, and there is a very long time
> delays (somtimes 10-15 seconds) at the interface after taking actions,
> such as push live/stop live, turning devices on/off, refresh position
> status in multiD and more.
> The delay is at the interface, that is the devices are responding at
> real time when pressing any button but the software seems to be stuck
> for few second (up to 10-15 seconds).
>
> Can you help me figure it out?

Communication between one of your devices and MM is timing out. Have a
look at the Corelog file.  You may want to switch on debug mode (in
options) to get more output.  If that does not reveal the problem,
generate a trouble report, and I will have a look.

Best,


Nico


_______________________________________________
micro-manager-general mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/micro-manager-general