Micro-Manager and QSI CCD camera issue.

classic Classic list List threaded Threaded
5 messages Options
Reply | Threaded
Open this post in threaded view
|

Micro-Manager and QSI CCD camera issue.

Oksuz, Ibrahim

Hello,

 

I am so sorry if asking for help through this e-mail is not appropriate. Could you help me on an issue related to Micro-Manager?

 

 

I have a model 628 QSI CCD camera. I am using Micro-Manager as a software to take images. I installed all necessary drivers. I can see in device manager that the QSI camera is connected and properly working. However, when I try to snap an image, it gives an error seen below, 

 

 

 

I have contacted and asked for technical support from the camera vendor. However, I was told that I should contact Micro-manager people to have some information on whether this error refers to software or hardware issue.

 

 

Could please suggest a solution for this particular error? 

 

Thank you in advance. 

 

 

Best regards,

Ibrahim

 

Ph.D. Candidate

The Ohio State University

Nuclear Engineering Program

 



_______________________________________________
micro-manager-general mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/micro-manager-general
Reply | Threaded
Open this post in threaded view
|

Re: Micro-Manager and QSI CCD camera issue.

Stuurman, Nico
Hi Ibrahim,

>
> I have a model 628 QSI CCD camera. I am using Micro-Manager as a
> software to take images. I installed all necessary drivers. I can see
> in device manager that the QSI camera is connected and properly
> working. However, when I try to snap an image, it gives an error seen
> below,
>
> I have contacted and asked for technical support from the camera
> vendor. However, I was told that I should contact Micro-manager people
> to have some information on whether this error refers to software or
> hardware issue.
>


The source code for the QSI adapter is not in the Micro-Manager
repository, so "the Micro-Manager people" can not help you.  The error
you show comes from the QSI camera, so you should ask QSI (and/or the
author of the device adapter, whose name appears to be Mike Barry). 
While you are at it, ask them to send the source code to "the
Micro-Manager" people, so that you can start using newer versions of
Micro-Manager, and others can actually help fix the problem you report.

Best,


NIco



>



_______________________________________________
micro-manager-general mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/micro-manager-general
Reply | Threaded
Open this post in threaded view
|

Re: Micro-Manager and QSI CCD camera issue.

Micro-Manager mailing list
Hello Nico,

Thank you for the information you provided. Below is the response I got from QSI, 


"Unfortunately, in order to troubleshoot the issue, I need much more precise information than what they have currently given you

They wrote the application, so they must know what error 1058 actually refers to – we do not have any of this information."



Could you tell me what error 1058 refers to for Micro-Manager? 

Best,
Ibrahim. 


On Monday, May 20, 2019, 1:59:13 PM EDT, Stuurman, Nico <[hidden email]> wrote:


Hi Ibrahim,

>
> I have a model 628 QSI CCD camera. I am using Micro-Manager as a
> software to take images. I installed all necessary drivers. I can see
> in device manager that the QSI camera is connected and properly
> working. However, when I try to snap an image, it gives an error seen
> below,
>
> I have contacted and asked for technical support from the camera
> vendor. However, I was told that I should contact Micro-manager people
> to have some information on whether this error refers to software or
> hardware issue.
>


The source code for the QSI adapter is not in the Micro-Manager
repository, so "the Micro-Manager people" can not help you.  The error
you show comes from the QSI camera, so you should ask QSI (and/or the
author of the device adapter, whose name appears to be Mike Barry). 
While you are at it, ask them to send the source code to "the
Micro-Manager" people, so that you can start using newer versions of
Micro-Manager, and others can actually help fix the problem you report.

Best,


NIco




>



_______________________________________________
micro-manager-general mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/micro-manager-general


_______________________________________________
micro-manager-general mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/micro-manager-general
Reply | Threaded
Open this post in threaded view
|

Re: Micro-Manager and QSI CCD camera issue.

Stuurman, Nico
On 5/22/19 11:43 AM, Ibrahim Öksüz via micro-manager-general wrote:

> Hello Nico,
>
> Thank you for the information you provided. Below is the response I
> got from QSI,
>
>
> *"Unfortunately, in order to troubleshoot the issue, I need much more
> precise information than what they have currently given you*
>
> *They wrote the application, so they must know what error 1058
> actually refers to – we do not have any of this information."*
>
>
>
> Could you tell me what error 1058 refers to for Micro-Manager?


They have it wrong.  They wrote the device adapter code, and do not make
that device adapter code publicly available.  The error is coming from
their code (either the device adapter or their driver). The source code
for Micro-manager is publicly available
(https://valelab4.ucsf.edu/svn/micromanager2/trunk/), and you can search
it yourself for this error code.  I did, and nothing turned up.  You can
ask them for the source code to their device adapter. If they do not
give that to you, I would sell the camera (and never buy one of these
again).


Best,


Nico




_______________________________________________
micro-manager-general mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/micro-manager-general
Reply | Threaded
Open this post in threaded view
|

Re: Micro-Manager and QSI CCD camera issue.

tron
Nico,
just FYI, it seems the initialization code of the IX83 hub has some
quircks, today we had:

Error: Failed to load hardware configuation
Line 27: Property,Core,Initialize,1
Error in device "Olympus IX83": Exception: Error: Could not open
interface. at
e:\mm2gammagitbuild\micro-manager\secretdeviceadapters\olympusix83\Hub.h:130
(2147483647)

(configuation typo is verbatim)

Problem resolved after a full restart of the IX83.

I'm trying to put some pressure on local Olympus rep to get access to
the code. This may be related to the control hub entering some sleep mode ?

-Carlos

Stuurman, Nico @ 22/05/2019 18:46 -0300 dixit:

> Hi Carlos,
>
> I would contact our local Olympus rep, and you should probably do the
> same. I would not forget about it.  Olympus needs to hear this from as
> many people as possible.  Sales reps are always the best way in, since
> these people really want to help you, and the higher ups tend to listen
> to them (since they sell stuff;)
>
> Best,
>
> Nico

--
Carlos G Mendioroz  <[hidden email]>


_______________________________________________
micro-manager-general mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/micro-manager-general
--
Carlos G Mendioroz