Propblems setting the Pre-Amp-Gain with Ixon897

classic Classic list List threaded Threaded
6 messages Options
Reply | Threaded
Open this post in threaded view
|

Propblems setting the Pre-Amp-Gain with Ixon897

benjamin.rost
Hello,

I'm using an Andor Ixon897 with Micro-Manager 1.4.14. The camera offers to
change the preamplifier gain to 2.4 and 4.9. This feature creates error
codes in Micro-Manager (Pre-Amp-Gain: Error Code 3). In the menue allowing
to set the pre-amp-gain, MM offers 1x, 2.4xP¾□, and 4.9xP¾□.
How can I fix this?

Thanks for your work and efforts!
Best,
Benjamin



--
Benjamin Rost, PhD

Charité - Universitätsmedizin Berlin
CCO - NeuroCure
AG Rosenmund
Charitéplatz 1
(intern Virchowweg 6, Gebäude 2360)
D-10117 Berlin

Tel: (+49) 30-450639080
Fax: (+49) 30-450539920


------------------------------------------------------------------------------
Try New Relic Now & We'll Send You this Cool Shirt
New Relic is the only SaaS-based application performance monitoring service
that delivers powerful full stack analytics. Optimize and monitor your
browser, app, & servers with just a few lines of code. Try New Relic
and get this awesome Nerd Life shirt! http://p.sf.net/sfu/newrelic_d2d_apr
_______________________________________________
micro-manager-general mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/micro-manager-general
Reply | Threaded
Open this post in threaded view
|

Re: Propblems setting the Pre-Amp-Gain with Ixon897

Pariksheet Nanda
On Tue, Apr 23, 2013 at 5:08 AM, Dr. Benjamin Rost
<[hidden email]> wrote:
> I'm using an Andor Ixon897 with Micro-Manager 1.4.14. The camera offers to
> change the preamplifier gain to 2.4 and 4.9. This feature creates error
> codes in Micro-Manager (Pre-Amp-Gain: Error Code 3). In the menu allowing
> to set the pre-amp-gain, MM offers 1x, 2.4x, and 4.9x.
> How can I fix this?
>

What is the value of ReadoutMode when you see this error?  Does it
happen with other ReadoutMode speeds?
Can you advise the serial number of your camera?  It will be something
like X-1234


> Benjamin

Pariksheet

------------------------------------------------------------------------------
Try New Relic Now & We'll Send You this Cool Shirt
New Relic is the only SaaS-based application performance monitoring service
that delivers powerful full stack analytics. Optimize and monitor your
browser, app, & servers with just a few lines of code. Try New Relic
and get this awesome Nerd Life shirt! http://p.sf.net/sfu/newrelic_d2d_apr
_______________________________________________
micro-manager-general mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/micro-manager-general
Reply | Threaded
Open this post in threaded view
|

Re: Propblems setting the Pre-Amp-Gain with Ixon897

benjamin.rost
Dear Pariksheet,

the readout mode is 10.000MHz, but I have the problem also at any other mode. I installed also the last nigthly-build and an older version of MM (1.4.12), all had the same issue.
The camera model is DU-897D-COO-#BV
The serial-number is X-7801.

All the other settings work, it is just the pr-amp gain.

Thanks for your help!
Best,
Benajmin
Reply | Threaded
Open this post in threaded view
|

Re: Propblems setting the Pre-Amp-Gain with Ixon897

Pariksheet Nanda
On Wed, Apr 24, 2013 at 5:57 AM, benjamin.rost <[hidden email]> wrote:
> the readout mode is 10.000MHz, but I have the problem also at any other
> mode. I installed also the last nigthly-build and an older version of MM
> (1.4.12), all had the same issue.
>

I managed to reproduce your problem.
The error seems to be from those crazy characters at the end of the 1x
and 2.4x strings.
(At first I thought seeing those characters was a problem in the
e-mail but those characters are actually in the Micro-Manager
Pre-Amp-Gain Property)
Interestingly on my system the fault only happens with the 2.4x
setting, and only with 32-bit Micro-Manager
I don't see the issue with 64-bit Micro-Manager.
Using the latest Andor SDK 2.94.30007.0 DLL does not help either.

Are you using 32- or 64-bit Micro-Manager?
Also which operating system are you using?

Once I know that I'll report this bug since Andor maintains the DeviceAdapter.


> Benajmin

Pariksheet

------------------------------------------------------------------------------
Try New Relic Now & We'll Send You this Cool Shirt
New Relic is the only SaaS-based application performance monitoring service
that delivers powerful full stack analytics. Optimize and monitor your
browser, app, & servers with just a few lines of code. Try New Relic
and get this awesome Nerd Life shirt! http://p.sf.net/sfu/newrelic_d2d_apr
_______________________________________________
micro-manager-general mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/micro-manager-general
Reply | Threaded
Open this post in threaded view
|

Re: Propblems setting the Pre-Amp-Gain with Ixon897

benjamin.rost
Pariksheet Nanda wrote
The error seems to be from those crazy characters at the end of the 1x
and 2.4x strings.... Interestingly on my system the fault only happens with the 2.4x
setting, and only with 32-bit Micro-Manager
I don't see the issue with 64-bit Micro-Manager.
Using the latest Andor SDK 2.94.30007.0 DLL does not help either.
Are you using 32- or 64-bit Micro-Manager?
Also which operating system are you using?
The "crazy" characters are indeed the problem. I have them for the 2.4x and 4.9x pre-amp gain, but not for the 1x. They are not static, but increase in number when I try to change them repetitively.  I'm using 32-bit Micro-Manager on a Windows XP OS, and Andor_SDK2_2.94.30007.0.

Best,
Benjamin
Reply | Threaded
Open this post in threaded view
|

Re: Propblems setting the Pre-Amp-Gain with Ixon897

Pariksheet Nanda
On Thu, Apr 25, 2013 at 5:29 AM, benjamin.rost <[hidden email]> wrote:
> The "crazy" characters are indeed the problem.
>

Updating the list on this issue-

This bug has been fixed by the Andor software team.
Both of Dr. Rost and I tested the patch addresses the Pre-Amp-Gain
property label with our cameras.
I tested the fix is works in Windows 32-bit nightly build 20130430
(change is svn 10884 committed 2 days ago)

Thanks for reporting,
Pariksheet

------------------------------------------------------------------------------
Introducing AppDynamics Lite, a free troubleshooting tool for Java/.NET
Get 100% visibility into your production application - at no cost.
Code-level diagnostics for performance bottlenecks with <2% overhead
Download for free and get started troubleshooting in minutes.
http://p.sf.net/sfu/appdyn_d2d_ap1
_______________________________________________
micro-manager-general mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/micro-manager-general