RAMPS device adapter - variable movement and a potential bug in the Z axis movement

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

RAMPS device adapter - variable movement and a potential bug in the Z axis movement

Straub, Volko A. (Dr.)

Dear All,

 

Using the RAMPS device adapter to control my motorised XYZ stage I noticed two issues and was wondering if anybody had any thoughts or suggestions.

 

1.       Requesting the stage to move a certain distance in the X or Y axis produces quite variable results. I sort of half expected some issues with backlash when changing travel directions or on the first step, but even repeated movements by the same distance (e.g. repeatedly clicking the left arrow of the stage control panel to move the stage by 100 um) can result in actual movements anywhere between ~75 um and ~105 um. I have tried to change (reduce) the feed rate and acceleration parameters in the Sprinter firmware, but it doesn’t appear to have any effect. Does anybody have any ideas how to make the movements more reproducible?

 

2.       Odd behaviour of the Z control in the stage control panel (maybe be related to a previously reported issue that only allowed steps larger than 5 um):

 

a.       Clicking the single arrow for the Z axis does not move the Z axis when the displayed position is <= 0 um (clicking double arrow up or down moves the stage)

b.      Clicking the single arrow for the Z axis reports movements of 5 um when step size is set to values between 2.5 and 5 um (no movement for step sizes smaller than 2.5 um)

c.       Clicking the double arrow down for the Z axis produces a reported move of 5 um less than the set distance when displayed Z position is negative.

d.      Clicking the double arrow up for the Z axis produces a reported move of 5 um more than the set distance when displayed Z position is positive.

 

Thanks for any comments/suggestions,

Volko

 



_______________________________________________
micro-manager-general mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/micro-manager-general
Reply | Threaded
Open this post in threaded view
|

Re: RAMPS device adapter - variable movement and a potential bug in the Z axis movement

tron


Straub, Volko A. (Dr.) @ 14/08/2019 13:10 -0600 dixit:

> 1.       Requesting the stage to move a certain distance in the X or Y
> axis produces quite variable results. I sort of half expected some
> issues with backlash when changing travel directions or on the first
> step, but even repeated movements by the same distance (e.g. repeatedly
> clicking the left arrow of the stage control panel to move the stage by
> 100 um) can result in actual movements anywhere between ~75 um and ~105
> um. I have tried to change (reduce) the feed rate and acceleration
> parameters in the Sprinter firmware, but it doesn’t appear to have any
> effect. Does anybody have any ideas how to make the movements more
> reproducible?

I would start by determining if the problem is with uM (I doubt that) or
with the stage. To this end, you'd better learn the basics of GCODE, and
using a terminal emulator drive the stage and see if it works ok or not.

What is your step/mm ratio ? Are you using microsteps ?


--
Carlos G Mendioroz  <[hidden email]>


_______________________________________________
micro-manager-general mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/micro-manager-general
--
Carlos G Mendioroz