Re: (QUAR} Re: Building micro-manager on ubuntu 18.04

classic Classic list List threaded Threaded
9 messages Options
Reply | Threaded
Open this post in threaded view
|

Re: (QUAR} Re: Building micro-manager on ubuntu 18.04

Stuurman, Nico
Clearly, the needed Java dependencies are not found.

After running make fetchdeps, look at the output and see if anything is missing.  You can also look at the content of dependencies/artifacts/compile. 

We build MM (most versions) daily, and it seems to work nicely, so either you are skipping a step, something is different in your setup, or something completely different is going on;)

Best,

Nico

On 5/8/2019 12:58 AM, [hidden email] wrote:

Hi Aurélien,

 

I am using same Jave version on Ubuntu 18 without any problem.  But I am facing same issue on Mac.

 

javabuild.xml:110:

 

I have alrady posted this yesterday. I hope will get futher hint to fix this issue today.

 

 

BR

Ravi

 

-----Ursprüngliche Nachricht-----
Von: "Aurélien Courtois" [[hidden email]]
Gesendet: Mi. 08.05.2019 09:38
An: [hidden email]
Betreff: [micro-manager-general] Building micro-manager on ubuntu 18.04

Dear all,
I am sorry if my question is trivial, I have not much experience with building manager in Unix system, but I am trying to install micromanager on Ubuntu 18.04 following all steps on "https://protect2.fireeye.com/url?k=bc76ace2-e03699dc-bc768bff-0cc47ad9c120-aec5d09e9fba3b48&u=https://micro-manager.org/wiki/Linux_installation_from_source_(Ubuntu)" and i get this error message after "make":

> mmstudio.compile:
>   [mm-javac] Compiling 272 source files to /home/aure/mm/micro-manager1.4/mmstudio/build
>   [mm-javac] warning: [options] bootstrap class path not set in conjunction with -source 6
>   [mm-javac] warning: [options] source value 6 is obsolete and will be removed in a future release
>   [mm-javac] warning: [options] target value 1.6 is obsolete and will be removed in a future release
>   [mm-javac] warning: [options] To suppress warnings about obsolete options, use -Xlint:-options.
>   [mm-javac] /home/aure/mm/micro-manager1.4/mmstudio/src/org/micromanager/navigation/CenterAndDragListener.java:11: warning: [deprecation] Event in java.awt has been deprecated
>   [mm-javac] import java.awt.Event;
>   [mm-javac]                ^
>   [mm-javac] warning: No processor claimed any of these annotations: com.google.common.eventbus.Subscribe
>   [mm-javac] /home/aure/mm/micro-manager1.4/mmstudio/src/org/micromanager/navigation/CenterAndDragListener.java:11: warning: [deprecation] Event in java.awt has been deprecated
>   [mm-javac] import java.awt.Event;
>   [mm-javac]                ^
>   [mm-javac] /home/aure/mm/micro-manager1.4/mmstudio/src/org/micromanager/acquisition/OMEMetadata.java:26: error: package loci.common does not exist
>   [mm-javac] import loci.common.DateTools;
>   [mm-javac]                   ^
>   [mm-javac] /home/aure/mm/micro-manager1.4/mmstudio/src/org/micromanager/acquisition/OMEMetadata.java:27: error: package loci.common.services does not exist
>   [mm-javac] import loci.common.services.ServiceFactory;
>   [mm-javac]                            ^
>   [mm-javac] /home/aure/mm/micro-manager1.4/mmstudio/src/org/micromanager/acquisition/OMEMetadata.java:28: error: package loci.formats does not exist
>   [mm-javac] import loci.formats.MetadataTools;
>   [mm-javac]                    ^
>   [mm-javac] /home/aure/mm/micro-manager1.4/mmstudio/src/org/micromanager/acquisition/OMEMetadata.java:29: error: package loci.formats.meta does not exist
>   [mm-javac] import loci.formats.meta.IMetadata;
>   [mm-javac]                         ^
>   [mm-javac] /home/aure/mm/micro-manager1.4/mmstudio/src/org/micromanager/acquisition/OMEMetadata.java:30: error: package loci.formats.services does not exist
>   [mm-javac] import loci.formats.services.OMEXMLService;
>   [mm-javac]                             ^
>   [mm-javac] /home/aure/mm/micro-manager1.4/mmstudio/src/org/micromanager/acquisition/OMEMetadata.java:31: error: package ome.units does not exist
>   [mm-javac] import ome.units.UNITS;
>   [mm-javac]                 ^
>   [mm-javac] /home/aure/mm/micro-manager1.4/mmstudio/src/org/micromanager/acquisition/OMEMetadata.java:32: error: package ome.units.quantity does not exist
>   [mm-javac] import ome.units.quantity.Length;
>   [mm-javac]                          ^
>   [mm-javac] /home/aure/mm/micro-manager1.4/mmstudio/src/org/micromanager/acquisition/OMEMetadata.java:33: error: package ome.units.quantity does not exist
>   [mm-javac] import ome.units.quantity.Time;
>   [mm-javac]                          ^
>   [mm-javac] /home/aure/mm/micro-manager1.4/mmstudio/src/org/micromanager/acquisition/OMEMetadata.java:47: error: cannot find symbol
>   [mm-javac]    private IMetadata metadata_;
>   [mm-javac]            ^
>   [mm-javac]   symbol:   class IMetadata
>   [mm-javac]   location: class OMEMetadata
>   [mm-javac] 9 errors
>   [mm-javac] 7 warnings
>
> BUILD FAILED
> /home/aure/mm/micro-manager1.4/buildscripts/javabuild.xml:110: Compile failed; see the compiler error output for details.
>
> Total time: 2 seconds
> Makefile:888: recipe for target 'MMJ_.jar' failed
> make[1]: *** [MMJ_.jar] Error 1
> make[1]: Leaving directory '/home/aure/mm/micro-manager1.4/mmstudio'
> Makefile:521: recipe for target 'all-recursive' failed
> make: *** [all-recursive] Error 1
(ps; i am using openjdk-11-jdk, except this everything is done exactly the same way as in the instruction, i tried also with openjdk-8-jdk instead of 11.)

And i am quite lost, i have no idea what causes this and what i can do to manage to build micromanager. I would be very thankful if you could help me or orient me to other posts about similar problems, that i unfortunately couldn't find.
Best,
 Aurelien

-----Ursprüngliche Nachricht Ende-----




_______________________________________________
micro-manager-general mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/micro-manager-general





_______________________________________________
micro-manager-general mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/micro-manager-general
Reply | Threaded
Open this post in threaded view
|

Re: (QUAR} Re: Building micro-manager on ubuntu 18.04

Aurélien Courtois
Thank you for your inputs,
When i make fetchdeps i get warnings:
WARNING: An illegal reflective access operation has occurred
WARNING: Illegal reflective access by org.apache.ivy.util.url.IvyAuthenticator (file:/home/aure/mm/micro-manager1.4/dependencies/ivy/ivy-2.3.0.jar) to field java.net.Authenticator.theAuthenticator
WARNING: Please consider reporting this to the maintainers of org.apache.ivy.util.url.IvyAuthenticator
WARNING: Use --illegal-access=warn to enable warnings of further illegal reflective access operations
WARNING: All illegal access operations will be denied in a future release

Problem summary:
[ivy:resolve] :: problems summary ::
[ivy:resolve] :::: WARNINGS
[ivy:resolve]   module not found: ome#formats-api;5.1.1
[ivy:resolve] :: sc.fiji#spim_data;2.0.1: not found
[ivy:resolve] :: net.imglib2#imglib2-realtransform;2.0.0-beta-29: not found
[ivy:resolve]   :: sc.fiji#bigdataviewer-core;2.1.0: not found
[ivy:resolve]   :: #ij3d-bin;: not found
[ivy:resolve]   :: #ima3d_;: not found
[ivy:resolve]   :: #DT1.2;: not found

but says Build successful.
Problem is same with version 1.4 or gamma 2.0.

Did i miss something basic ?
Best,
Aurelien





Le jeu. 9 mai 2019 à 04:05, Stuurman, Nico <[hidden email]> a écrit :
Clearly, the needed Java dependencies are not found.

After running make fetchdeps, look at the output and see if anything is missing.  You can also look at the content of dependencies/artifacts/compile. 

We build MM (most versions) daily, and it seems to work nicely, so either you are skipping a step, something is different in your setup, or something completely different is going on;)

Best,

Nico

On 5/8/2019 12:58 AM, [hidden email] wrote:

Hi Aurélien,

 

I am using same Jave version on Ubuntu 18 without any problem.  But I am facing same issue on Mac.

 

javabuild.xml:110:

 

I have alrady posted this yesterday. I hope will get futher hint to fix this issue today.

 

 

BR

Ravi

 

-----Ursprüngliche Nachricht-----
Von: "Aurélien Courtois" [[hidden email]]
Gesendet: Mi. 08.05.2019 09:38
An: [hidden email]
Betreff: [micro-manager-general] Building micro-manager on ubuntu 18.04

Dear all,
I am sorry if my question is trivial, I have not much experience with building manager in Unix system, but I am trying to install micromanager on Ubuntu 18.04 following all steps on "https://protect2.fireeye.com/url?k=bc76ace2-e03699dc-bc768bff-0cc47ad9c120-aec5d09e9fba3b48&u=https://micro-manager.org/wiki/Linux_installation_from_source_(Ubuntu)" and i get this error message after "make":

> mmstudio.compile:
>   [mm-javac] Compiling 272 source files to /home/aure/mm/micro-manager1.4/mmstudio/build
>   [mm-javac] warning: [options] bootstrap class path not set in conjunction with -source 6
>   [mm-javac] warning: [options] source value 6 is obsolete and will be removed in a future release
>   [mm-javac] warning: [options] target value 1.6 is obsolete and will be removed in a future release
>   [mm-javac] warning: [options] To suppress warnings about obsolete options, use -Xlint:-options.
>   [mm-javac] /home/aure/mm/micro-manager1.4/mmstudio/src/org/micromanager/navigation/CenterAndDragListener.java:11: warning: [deprecation] Event in java.awt has been deprecated
>   [mm-javac] import java.awt.Event;
>   [mm-javac]                ^
>   [mm-javac] warning: No processor claimed any of these annotations: com.google.common.eventbus.Subscribe
>   [mm-javac] /home/aure/mm/micro-manager1.4/mmstudio/src/org/micromanager/navigation/CenterAndDragListener.java:11: warning: [deprecation] Event in java.awt has been deprecated
>   [mm-javac] import java.awt.Event;
>   [mm-javac]                ^
>   [mm-javac] /home/aure/mm/micro-manager1.4/mmstudio/src/org/micromanager/acquisition/OMEMetadata.java:26: error: package loci.common does not exist
>   [mm-javac] import loci.common.DateTools;
>   [mm-javac]                   ^
>   [mm-javac] /home/aure/mm/micro-manager1.4/mmstudio/src/org/micromanager/acquisition/OMEMetadata.java:27: error: package loci.common.services does not exist
>   [mm-javac] import loci.common.services.ServiceFactory;
>   [mm-javac]                            ^
>   [mm-javac] /home/aure/mm/micro-manager1.4/mmstudio/src/org/micromanager/acquisition/OMEMetadata.java:28: error: package loci.formats does not exist
>   [mm-javac] import loci.formats.MetadataTools;
>   [mm-javac]                    ^
>   [mm-javac] /home/aure/mm/micro-manager1.4/mmstudio/src/org/micromanager/acquisition/OMEMetadata.java:29: error: package loci.formats.meta does not exist
>   [mm-javac] import loci.formats.meta.IMetadata;
>   [mm-javac]                         ^
>   [mm-javac] /home/aure/mm/micro-manager1.4/mmstudio/src/org/micromanager/acquisition/OMEMetadata.java:30: error: package loci.formats.services does not exist
>   [mm-javac] import loci.formats.services.OMEXMLService;
>   [mm-javac]                             ^
>   [mm-javac] /home/aure/mm/micro-manager1.4/mmstudio/src/org/micromanager/acquisition/OMEMetadata.java:31: error: package ome.units does not exist
>   [mm-javac] import ome.units.UNITS;
>   [mm-javac]                 ^
>   [mm-javac] /home/aure/mm/micro-manager1.4/mmstudio/src/org/micromanager/acquisition/OMEMetadata.java:32: error: package ome.units.quantity does not exist
>   [mm-javac] import ome.units.quantity.Length;
>   [mm-javac]                          ^
>   [mm-javac] /home/aure/mm/micro-manager1.4/mmstudio/src/org/micromanager/acquisition/OMEMetadata.java:33: error: package ome.units.quantity does not exist
>   [mm-javac] import ome.units.quantity.Time;
>   [mm-javac]                          ^
>   [mm-javac] /home/aure/mm/micro-manager1.4/mmstudio/src/org/micromanager/acquisition/OMEMetadata.java:47: error: cannot find symbol
>   [mm-javac]    private IMetadata metadata_;
>   [mm-javac]            ^
>   [mm-javac]   symbol:   class IMetadata
>   [mm-javac]   location: class OMEMetadata
>   [mm-javac] 9 errors
>   [mm-javac] 7 warnings
>
> BUILD FAILED
> /home/aure/mm/micro-manager1.4/buildscripts/javabuild.xml:110: Compile failed; see the compiler error output for details.
>
> Total time: 2 seconds
> Makefile:888: recipe for target 'MMJ_.jar' failed
> make[1]: *** [MMJ_.jar] Error 1
> make[1]: Leaving directory '/home/aure/mm/micro-manager1.4/mmstudio'
> Makefile:521: recipe for target 'all-recursive' failed
> make: *** [all-recursive] Error 1
(ps; i am using openjdk-11-jdk, except this everything is done exactly the same way as in the instruction, i tried also with openjdk-8-jdk instead of 11.)

And i am quite lost, i have no idea what causes this and what i can do to manage to build micromanager. I would be very thankful if you could help me or orient me to other posts about similar problems, that i unfortunately couldn't find.
Best,
 Aurelien

-----Ursprüngliche Nachricht Ende-----




_______________________________________________
micro-manager-general mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/micro-manager-general



_______________________________________________
micro-manager-general mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/micro-manager-general



_______________________________________________
micro-manager-general mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/micro-manager-general
Reply | Threaded
Open this post in threaded view
|

Re: Building micro-manager on ubuntu 18.04 (and MMbuild on Mac)

Stuurman, Nico
This issue is caused by the imagej.net maven repository disappearing.  I posted this on the Image forum:  https://forum.image.sc/t/imagej-net-maven-repository-disappeared/25509

Hopefully someone there knows where these files went.  Otherwise, we'll need to host our copies locally...

B.t.w., the last three (#ij3d-bin, #ima3d_, #DT1.2) are in 3rdpartypublicnonfree, which is in our 3rdparty repository, which is not accessible to you, hence you can not build code that relies on these (I have no idea what code that is...).

Best,

Nico

On 5/8/2019 8:46 PM, Aurélien Courtois wrote:
Thank you for your inputs,
When i make fetchdeps i get warnings:
WARNING: An illegal reflective access operation has occurred
WARNING: Illegal reflective access by org.apache.ivy.util.url.IvyAuthenticator (file:/home/aure/mm/micro-manager1.4/dependencies/ivy/ivy-2.3.0.jar) to field java.net.Authenticator.theAuthenticator
WARNING: Please consider reporting this to the maintainers of org.apache.ivy.util.url.IvyAuthenticator
WARNING: Use --illegal-access=warn to enable warnings of further illegal reflective access operations
WARNING: All illegal access operations will be denied in a future release

Problem summary:
[ivy:resolve] :: problems summary ::
[ivy:resolve] :::: WARNINGS
[ivy:resolve]   module not found: ome#formats-api;5.1.1
[ivy:resolve] :: sc.fiji#spim_data;2.0.1: not found
[ivy:resolve] :: net.imglib2#imglib2-realtransform;2.0.0-beta-29: not found
[ivy:resolve]   :: sc.fiji#bigdataviewer-core;2.1.0: not found
[ivy:resolve]   :: #ij3d-bin;: not found
[ivy:resolve]   :: #ima3d_;: not found
[ivy:resolve]   :: #DT1.2;: not found

but says Build successful.
Problem is same with version 1.4 or gamma 2.0.

Did i miss something basic ?
Best,
Aurelien





Le jeu. 9 mai 2019 à 04:05, Stuurman, Nico <[hidden email]> a écrit :
Clearly, the needed Java dependencies are not found.

After running make fetchdeps, look at the output and see if anything is missing.  You can also look at the content of dependencies/artifacts/compile. 

We build MM (most versions) daily, and it seems to work nicely, so either you are skipping a step, something is different in your setup, or something completely different is going on;)

Best,

Nico

On 5/8/2019 12:58 AM, [hidden email] wrote:

Hi Aurélien,

 

I am using same Jave version on Ubuntu 18 without any problem.  But I am facing same issue on Mac.

 

javabuild.xml:110:

 

I have alrady posted this yesterday. I hope will get futher hint to fix this issue today.

 

 

BR

Ravi

 

-----Ursprüngliche Nachricht-----
Von: "Aurélien Courtois" [[hidden email]]
Gesendet: Mi. 08.05.2019 09:38
An: [hidden email]
Betreff: [micro-manager-general] Building micro-manager on ubuntu 18.04

Dear all,
I am sorry if my question is trivial, I have not much experience with building manager in Unix system, but I am trying to install micromanager on Ubuntu 18.04 following all steps on "https://protect2.fireeye.com/url?k=bc76ace2-e03699dc-bc768bff-0cc47ad9c120-aec5d09e9fba3b48&u=https://micro-manager.org/wiki/Linux_installation_from_source_(Ubuntu)" and i get this error message after "make":

> mmstudio.compile:
>   [mm-javac] Compiling 272 source files to /home/aure/mm/micro-manager1.4/mmstudio/build
>   [mm-javac] warning: [options] bootstrap class path not set in conjunction with -source 6
>   [mm-javac] warning: [options] source value 6 is obsolete and will be removed in a future release
>   [mm-javac] warning: [options] target value 1.6 is obsolete and will be removed in a future release
>   [mm-javac] warning: [options] To suppress warnings about obsolete options, use -Xlint:-options.
>   [mm-javac] /home/aure/mm/micro-manager1.4/mmstudio/src/org/micromanager/navigation/CenterAndDragListener.java:11: warning: [deprecation] Event in java.awt has been deprecated
>   [mm-javac] import java.awt.Event;
>   [mm-javac]                ^
>   [mm-javac] warning: No processor claimed any of these annotations: com.google.common.eventbus.Subscribe
>   [mm-javac] /home/aure/mm/micro-manager1.4/mmstudio/src/org/micromanager/navigation/CenterAndDragListener.java:11: warning: [deprecation] Event in java.awt has been deprecated
>   [mm-javac] import java.awt.Event;
>   [mm-javac]                ^
>   [mm-javac] /home/aure/mm/micro-manager1.4/mmstudio/src/org/micromanager/acquisition/OMEMetadata.java:26: error: package loci.common does not exist
>   [mm-javac] import loci.common.DateTools;
>   [mm-javac]                   ^
>   [mm-javac] /home/aure/mm/micro-manager1.4/mmstudio/src/org/micromanager/acquisition/OMEMetadata.java:27: error: package loci.common.services does not exist
>   [mm-javac] import loci.common.services.ServiceFactory;
>   [mm-javac]                            ^
>   [mm-javac] /home/aure/mm/micro-manager1.4/mmstudio/src/org/micromanager/acquisition/OMEMetadata.java:28: error: package loci.formats does not exist
>   [mm-javac] import loci.formats.MetadataTools;
>   [mm-javac]                    ^
>   [mm-javac] /home/aure/mm/micro-manager1.4/mmstudio/src/org/micromanager/acquisition/OMEMetadata.java:29: error: package loci.formats.meta does not exist
>   [mm-javac] import loci.formats.meta.IMetadata;
>   [mm-javac]                         ^
>   [mm-javac] /home/aure/mm/micro-manager1.4/mmstudio/src/org/micromanager/acquisition/OMEMetadata.java:30: error: package loci.formats.services does not exist
>   [mm-javac] import loci.formats.services.OMEXMLService;
>   [mm-javac]                             ^
>   [mm-javac] /home/aure/mm/micro-manager1.4/mmstudio/src/org/micromanager/acquisition/OMEMetadata.java:31: error: package ome.units does not exist
>   [mm-javac] import ome.units.UNITS;
>   [mm-javac]                 ^
>   [mm-javac] /home/aure/mm/micro-manager1.4/mmstudio/src/org/micromanager/acquisition/OMEMetadata.java:32: error: package ome.units.quantity does not exist
>   [mm-javac] import ome.units.quantity.Length;
>   [mm-javac]                          ^
>   [mm-javac] /home/aure/mm/micro-manager1.4/mmstudio/src/org/micromanager/acquisition/OMEMetadata.java:33: error: package ome.units.quantity does not exist
>   [mm-javac] import ome.units.quantity.Time;
>   [mm-javac]                          ^
>   [mm-javac] /home/aure/mm/micro-manager1.4/mmstudio/src/org/micromanager/acquisition/OMEMetadata.java:47: error: cannot find symbol
>   [mm-javac]    private IMetadata metadata_;
>   [mm-javac]            ^
>   [mm-javac]   symbol:   class IMetadata
>   [mm-javac]   location: class OMEMetadata
>   [mm-javac] 9 errors
>   [mm-javac] 7 warnings
>
> BUILD FAILED
> /home/aure/mm/micro-manager1.4/buildscripts/javabuild.xml:110: Compile failed; see the compiler error output for details.
>
> Total time: 2 seconds
> Makefile:888: recipe for target 'MMJ_.jar' failed
> make[1]: *** [MMJ_.jar] Error 1
> make[1]: Leaving directory '/home/aure/mm/micro-manager1.4/mmstudio'
> Makefile:521: recipe for target 'all-recursive' failed
> make: *** [all-recursive] Error 1
(ps; i am using openjdk-11-jdk, except this everything is done exactly the same way as in the instruction, i tried also with openjdk-8-jdk instead of 11.)

And i am quite lost, i have no idea what causes this and what i can do to manage to build micromanager. I would be very thankful if you could help me or orient me to other posts about similar problems, that i unfortunately couldn't find.
Best,
 Aurelien

-----Ursprüngliche Nachricht Ende-----




_______________________________________________
micro-manager-general mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/micro-manager-general



_______________________________________________
micro-manager-general mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/micro-manager-general



_______________________________________________
micro-manager-general mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/micro-manager-general



_______________________________________________
micro-manager-general mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/micro-manager-general
Reply | Threaded
Open this post in threaded view
|

Re: Building micro-manager on ubuntu 18.04 (and MMbuild on Mac)

Stuurman, Nico
Turns out that the imagej maven repository was moved.

I updated the needed file in the 1.4 repository code.

Please let me know if 1.4 now builds for you (hard for me to test, since the downloaded files are cached, and I could move my cache, but rather see if it fixes it for you guys).  Once it is confirmed to work, I'll move it to 2.0-gamma.



On 5/9/2019 7:18 AM, Stuurman, Nico wrote:
This issue is caused by the imagej.net maven repository disappearing.  I posted this on the Image forum:  https://forum.image.sc/t/imagej-net-maven-repository-disappeared/25509

Hopefully someone there knows where these files went.  Otherwise, we'll need to host our copies locally...

B.t.w., the last three (#ij3d-bin, #ima3d_, #DT1.2) are in 3rdpartypublicnonfree, which is in our 3rdparty repository, which is not accessible to you, hence you can not build code that relies on these (I have no idea what code that is...).

Best,

Nico

On 5/8/2019 8:46 PM, Aurélien Courtois wrote:
Thank you for your inputs,
When i make fetchdeps i get warnings:
WARNING: An illegal reflective access operation has occurred
WARNING: Illegal reflective access by org.apache.ivy.util.url.IvyAuthenticator (file:/home/aure/mm/micro-manager1.4/dependencies/ivy/ivy-2.3.0.jar) to field java.net.Authenticator.theAuthenticator
WARNING: Please consider reporting this to the maintainers of org.apache.ivy.util.url.IvyAuthenticator
WARNING: Use --illegal-access=warn to enable warnings of further illegal reflective access operations
WARNING: All illegal access operations will be denied in a future release

Problem summary:
[ivy:resolve] :: problems summary ::
[ivy:resolve] :::: WARNINGS
[ivy:resolve]   module not found: ome#formats-api;5.1.1
[ivy:resolve] :: sc.fiji#spim_data;2.0.1: not found
[ivy:resolve] :: net.imglib2#imglib2-realtransform;2.0.0-beta-29: not found
[ivy:resolve]   :: sc.fiji#bigdataviewer-core;2.1.0: not found
[ivy:resolve]   :: #ij3d-bin;: not found
[ivy:resolve]   :: #ima3d_;: not found
[ivy:resolve]   :: #DT1.2;: not found

but says Build successful.
Problem is same with version 1.4 or gamma 2.0.

Did i miss something basic ?
Best,
Aurelien





Le jeu. 9 mai 2019 à 04:05, Stuurman, Nico <[hidden email]> a écrit :
Clearly, the needed Java dependencies are not found.

After running make fetchdeps, look at the output and see if anything is missing.  You can also look at the content of dependencies/artifacts/compile. 

We build MM (most versions) daily, and it seems to work nicely, so either you are skipping a step, something is different in your setup, or something completely different is going on;)

Best,

Nico

On 5/8/2019 12:58 AM, [hidden email] wrote:

Hi Aurélien,

 

I am using same Jave version on Ubuntu 18 without any problem.  But I am facing same issue on Mac.

 

javabuild.xml:110:

 

I have alrady posted this yesterday. I hope will get futher hint to fix this issue today.

 

 

BR

Ravi

 

-----Ursprüngliche Nachricht-----
Von: "Aurélien Courtois" [[hidden email]]
Gesendet: Mi. 08.05.2019 09:38
An: [hidden email]
Betreff: [micro-manager-general] Building micro-manager on ubuntu 18.04

Dear all,
I am sorry if my question is trivial, I have not much experience with building manager in Unix system, but I am trying to install micromanager on Ubuntu 18.04 following all steps on "https://protect2.fireeye.com/url?k=bc76ace2-e03699dc-bc768bff-0cc47ad9c120-aec5d09e9fba3b48&u=https://micro-manager.org/wiki/Linux_installation_from_source_(Ubuntu)" and i get this error message after "make":

> mmstudio.compile:
>   [mm-javac] Compiling 272 source files to /home/aure/mm/micro-manager1.4/mmstudio/build
>   [mm-javac] warning: [options] bootstrap class path not set in conjunction with -source 6
>   [mm-javac] warning: [options] source value 6 is obsolete and will be removed in a future release
>   [mm-javac] warning: [options] target value 1.6 is obsolete and will be removed in a future release
>   [mm-javac] warning: [options] To suppress warnings about obsolete options, use -Xlint:-options.
>   [mm-javac] /home/aure/mm/micro-manager1.4/mmstudio/src/org/micromanager/navigation/CenterAndDragListener.java:11: warning: [deprecation] Event in java.awt has been deprecated
>   [mm-javac] import java.awt.Event;
>   [mm-javac]                ^
>   [mm-javac] warning: No processor claimed any of these annotations: com.google.common.eventbus.Subscribe
>   [mm-javac] /home/aure/mm/micro-manager1.4/mmstudio/src/org/micromanager/navigation/CenterAndDragListener.java:11: warning: [deprecation] Event in java.awt has been deprecated
>   [mm-javac] import java.awt.Event;
>   [mm-javac]                ^
>   [mm-javac] /home/aure/mm/micro-manager1.4/mmstudio/src/org/micromanager/acquisition/OMEMetadata.java:26: error: package loci.common does not exist
>   [mm-javac] import loci.common.DateTools;
>   [mm-javac]                   ^
>   [mm-javac] /home/aure/mm/micro-manager1.4/mmstudio/src/org/micromanager/acquisition/OMEMetadata.java:27: error: package loci.common.services does not exist
>   [mm-javac] import loci.common.services.ServiceFactory;
>   [mm-javac]                            ^
>   [mm-javac] /home/aure/mm/micro-manager1.4/mmstudio/src/org/micromanager/acquisition/OMEMetadata.java:28: error: package loci.formats does not exist
>   [mm-javac] import loci.formats.MetadataTools;
>   [mm-javac]                    ^
>   [mm-javac] /home/aure/mm/micro-manager1.4/mmstudio/src/org/micromanager/acquisition/OMEMetadata.java:29: error: package loci.formats.meta does not exist
>   [mm-javac] import loci.formats.meta.IMetadata;
>   [mm-javac]                         ^
>   [mm-javac] /home/aure/mm/micro-manager1.4/mmstudio/src/org/micromanager/acquisition/OMEMetadata.java:30: error: package loci.formats.services does not exist
>   [mm-javac] import loci.formats.services.OMEXMLService;
>   [mm-javac]                             ^
>   [mm-javac] /home/aure/mm/micro-manager1.4/mmstudio/src/org/micromanager/acquisition/OMEMetadata.java:31: error: package ome.units does not exist
>   [mm-javac] import ome.units.UNITS;
>   [mm-javac]                 ^
>   [mm-javac] /home/aure/mm/micro-manager1.4/mmstudio/src/org/micromanager/acquisition/OMEMetadata.java:32: error: package ome.units.quantity does not exist
>   [mm-javac] import ome.units.quantity.Length;
>   [mm-javac]                          ^
>   [mm-javac] /home/aure/mm/micro-manager1.4/mmstudio/src/org/micromanager/acquisition/OMEMetadata.java:33: error: package ome.units.quantity does not exist
>   [mm-javac] import ome.units.quantity.Time;
>   [mm-javac]                          ^
>   [mm-javac] /home/aure/mm/micro-manager1.4/mmstudio/src/org/micromanager/acquisition/OMEMetadata.java:47: error: cannot find symbol
>   [mm-javac]    private IMetadata metadata_;
>   [mm-javac]            ^
>   [mm-javac]   symbol:   class IMetadata
>   [mm-javac]   location: class OMEMetadata
>   [mm-javac] 9 errors
>   [mm-javac] 7 warnings
>
> BUILD FAILED
> /home/aure/mm/micro-manager1.4/buildscripts/javabuild.xml:110: Compile failed; see the compiler error output for details.
>
> Total time: 2 seconds
> Makefile:888: recipe for target 'MMJ_.jar' failed
> make[1]: *** [MMJ_.jar] Error 1
> make[1]: Leaving directory '/home/aure/mm/micro-manager1.4/mmstudio'
> Makefile:521: recipe for target 'all-recursive' failed
> make: *** [all-recursive] Error 1
(ps; i am using openjdk-11-jdk, except this everything is done exactly the same way as in the instruction, i tried also with openjdk-8-jdk instead of 11.)

And i am quite lost, i have no idea what causes this and what i can do to manage to build micromanager. I would be very thankful if you could help me or orient me to other posts about similar problems, that i unfortunately couldn't find.
Best,
 Aurelien

-----Ursprüngliche Nachricht Ende-----




_______________________________________________
micro-manager-general mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/micro-manager-general



_______________________________________________
micro-manager-general mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/micro-manager-general



_______________________________________________
micro-manager-general mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/micro-manager-general



_______________________________________________
micro-manager-general mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/micro-manager-general



_______________________________________________
micro-manager-general mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/micro-manager-general
Reply | Threaded
Open this post in threaded view
|

Re: Building micro-manager on ubuntu 18.04 (and MMbuild on Mac)

Aurélien Courtois
Hi,
Thank you, but unfortunately it looks like i still have exactly the same error. I deleted my micromanager folder and get everything again from  https://valelab4.ucsf.edu/svn/ but it didn't solve the problem. If it solves it for others then i will clean up everything and re-install everything fresh.
Best,
Aure

Le jeu. 9 mai 2019 à 23:57, Stuurman, Nico <[hidden email]> a écrit :
Turns out that the imagej maven repository was moved.

I updated the needed file in the 1.4 repository code.

Please let me know if 1.4 now builds for you (hard for me to test, since the downloaded files are cached, and I could move my cache, but rather see if it fixes it for you guys).  Once it is confirmed to work, I'll move it to 2.0-gamma.



On 5/9/2019 7:18 AM, Stuurman, Nico wrote:
This issue is caused by the imagej.net maven repository disappearing.  I posted this on the Image forum:  https://forum.image.sc/t/imagej-net-maven-repository-disappeared/25509

Hopefully someone there knows where these files went.  Otherwise, we'll need to host our copies locally...

B.t.w., the last three (#ij3d-bin, #ima3d_, #DT1.2) are in 3rdpartypublicnonfree, which is in our 3rdparty repository, which is not accessible to you, hence you can not build code that relies on these (I have no idea what code that is...).

Best,

Nico

On 5/8/2019 8:46 PM, Aurélien Courtois wrote:
Thank you for your inputs,
When i make fetchdeps i get warnings:
WARNING: An illegal reflective access operation has occurred
WARNING: Illegal reflective access by org.apache.ivy.util.url.IvyAuthenticator (file:/home/aure/mm/micro-manager1.4/dependencies/ivy/ivy-2.3.0.jar) to field java.net.Authenticator.theAuthenticator
WARNING: Please consider reporting this to the maintainers of org.apache.ivy.util.url.IvyAuthenticator
WARNING: Use --illegal-access=warn to enable warnings of further illegal reflective access operations
WARNING: All illegal access operations will be denied in a future release

Problem summary:
[ivy:resolve] :: problems summary ::
[ivy:resolve] :::: WARNINGS
[ivy:resolve]   module not found: ome#formats-api;5.1.1
[ivy:resolve] :: sc.fiji#spim_data;2.0.1: not found
[ivy:resolve] :: net.imglib2#imglib2-realtransform;2.0.0-beta-29: not found
[ivy:resolve]   :: sc.fiji#bigdataviewer-core;2.1.0: not found
[ivy:resolve]   :: #ij3d-bin;: not found
[ivy:resolve]   :: #ima3d_;: not found
[ivy:resolve]   :: #DT1.2;: not found

but says Build successful.
Problem is same with version 1.4 or gamma 2.0.

Did i miss something basic ?
Best,
Aurelien





Le jeu. 9 mai 2019 à 04:05, Stuurman, Nico <[hidden email]> a écrit :
Clearly, the needed Java dependencies are not found.

After running make fetchdeps, look at the output and see if anything is missing.  You can also look at the content of dependencies/artifacts/compile. 

We build MM (most versions) daily, and it seems to work nicely, so either you are skipping a step, something is different in your setup, or something completely different is going on;)

Best,

Nico

On 5/8/2019 12:58 AM, [hidden email] wrote:

Hi Aurélien,

 

I am using same Jave version on Ubuntu 18 without any problem.  But I am facing same issue on Mac.

 

javabuild.xml:110:

 

I have alrady posted this yesterday. I hope will get futher hint to fix this issue today.

 

 

BR

Ravi

 

-----Ursprüngliche Nachricht-----
Von: "Aurélien Courtois" [[hidden email]]
Gesendet: Mi. 08.05.2019 09:38
An: [hidden email]
Betreff: [micro-manager-general] Building micro-manager on ubuntu 18.04

Dear all,
I am sorry if my question is trivial, I have not much experience with building manager in Unix system, but I am trying to install micromanager on Ubuntu 18.04 following all steps on "https://protect2.fireeye.com/url?k=bc76ace2-e03699dc-bc768bff-0cc47ad9c120-aec5d09e9fba3b48&u=https://micro-manager.org/wiki/Linux_installation_from_source_(Ubuntu)" and i get this error message after "make":

> mmstudio.compile:
>   [mm-javac] Compiling 272 source files to /home/aure/mm/micro-manager1.4/mmstudio/build
>   [mm-javac] warning: [options] bootstrap class path not set in conjunction with -source 6
>   [mm-javac] warning: [options] source value 6 is obsolete and will be removed in a future release
>   [mm-javac] warning: [options] target value 1.6 is obsolete and will be removed in a future release
>   [mm-javac] warning: [options] To suppress warnings about obsolete options, use -Xlint:-options.
>   [mm-javac] /home/aure/mm/micro-manager1.4/mmstudio/src/org/micromanager/navigation/CenterAndDragListener.java:11: warning: [deprecation] Event in java.awt has been deprecated
>   [mm-javac] import java.awt.Event;
>   [mm-javac]                ^
>   [mm-javac] warning: No processor claimed any of these annotations: com.google.common.eventbus.Subscribe
>   [mm-javac] /home/aure/mm/micro-manager1.4/mmstudio/src/org/micromanager/navigation/CenterAndDragListener.java:11: warning: [deprecation] Event in java.awt has been deprecated
>   [mm-javac] import java.awt.Event;
>   [mm-javac]                ^
>   [mm-javac] /home/aure/mm/micro-manager1.4/mmstudio/src/org/micromanager/acquisition/OMEMetadata.java:26: error: package loci.common does not exist
>   [mm-javac] import loci.common.DateTools;
>   [mm-javac]                   ^
>   [mm-javac] /home/aure/mm/micro-manager1.4/mmstudio/src/org/micromanager/acquisition/OMEMetadata.java:27: error: package loci.common.services does not exist
>   [mm-javac] import loci.common.services.ServiceFactory;
>   [mm-javac]                            ^
>   [mm-javac] /home/aure/mm/micro-manager1.4/mmstudio/src/org/micromanager/acquisition/OMEMetadata.java:28: error: package loci.formats does not exist
>   [mm-javac] import loci.formats.MetadataTools;
>   [mm-javac]                    ^
>   [mm-javac] /home/aure/mm/micro-manager1.4/mmstudio/src/org/micromanager/acquisition/OMEMetadata.java:29: error: package loci.formats.meta does not exist
>   [mm-javac] import loci.formats.meta.IMetadata;
>   [mm-javac]                         ^
>   [mm-javac] /home/aure/mm/micro-manager1.4/mmstudio/src/org/micromanager/acquisition/OMEMetadata.java:30: error: package loci.formats.services does not exist
>   [mm-javac] import loci.formats.services.OMEXMLService;
>   [mm-javac]                             ^
>   [mm-javac] /home/aure/mm/micro-manager1.4/mmstudio/src/org/micromanager/acquisition/OMEMetadata.java:31: error: package ome.units does not exist
>   [mm-javac] import ome.units.UNITS;
>   [mm-javac]                 ^
>   [mm-javac] /home/aure/mm/micro-manager1.4/mmstudio/src/org/micromanager/acquisition/OMEMetadata.java:32: error: package ome.units.quantity does not exist
>   [mm-javac] import ome.units.quantity.Length;
>   [mm-javac]                          ^
>   [mm-javac] /home/aure/mm/micro-manager1.4/mmstudio/src/org/micromanager/acquisition/OMEMetadata.java:33: error: package ome.units.quantity does not exist
>   [mm-javac] import ome.units.quantity.Time;
>   [mm-javac]                          ^
>   [mm-javac] /home/aure/mm/micro-manager1.4/mmstudio/src/org/micromanager/acquisition/OMEMetadata.java:47: error: cannot find symbol
>   [mm-javac]    private IMetadata metadata_;
>   [mm-javac]            ^
>   [mm-javac]   symbol:   class IMetadata
>   [mm-javac]   location: class OMEMetadata
>   [mm-javac] 9 errors
>   [mm-javac] 7 warnings
>
> BUILD FAILED
> /home/aure/mm/micro-manager1.4/buildscripts/javabuild.xml:110: Compile failed; see the compiler error output for details.
>
> Total time: 2 seconds
> Makefile:888: recipe for target 'MMJ_.jar' failed
> make[1]: *** [MMJ_.jar] Error 1
> make[1]: Leaving directory '/home/aure/mm/micro-manager1.4/mmstudio'
> Makefile:521: recipe for target 'all-recursive' failed
> make: *** [all-recursive] Error 1
(ps; i am using openjdk-11-jdk, except this everything is done exactly the same way as in the instruction, i tried also with openjdk-8-jdk instead of 11.)

And i am quite lost, i have no idea what causes this and what i can do to manage to build micromanager. I would be very thankful if you could help me or orient me to other posts about similar problems, that i unfortunately couldn't find.
Best,
 Aurelien

-----Ursprüngliche Nachricht Ende-----




_______________________________________________
micro-manager-general mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/micro-manager-general



_______________________________________________
micro-manager-general mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/micro-manager-general



_______________________________________________
micro-manager-general mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/micro-manager-general



_______________________________________________
micro-manager-general mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/micro-manager-general

_______________________________________________
micro-manager-general mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/micro-manager-general


_______________________________________________
micro-manager-general mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/micro-manager-general
Reply | Threaded
Open this post in threaded view
|

Re: Building micro-manager on ubuntu 18.04 (and MMbuild on Mac)

Stuurman, Nico
Hi all builders,

Thank you, but unfortunately it looks like i still have exactly the same error. I deleted my micromanager folder and get everything again from  https://valelab4.ucsf.edu/svn/ but it didn't solve the problem. If it solves it for others then i will clean up everything and re-install everything fresh.

Sorry about that.  Using https rather than http solves this (apparently, ivy does not like redirects).  I tested it and committed in revision 17028, so hopefully, it now really works for you too.  Pushed this through to gamma as well, so if 1.4 or 2.0-gamma does not build, please reply here on the mailing list.  Not sure what this does to 2.0-beta...


Best,

Nico



_______________________________________________
micro-manager-general mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/micro-manager-general
Reply | Threaded
Open this post in threaded view
|

Re: Building micro-manager on ubuntu 18.04 (and MMbuild on Mac)

T1000
In reply to this post by Stuurman, Nico

 

Hi Nico,

 

I have no access to my Mac today, so I have tested on fresh installed Ubuntu 19.

 

[mm-javac] /opt/mm/micro-manager1.4/mmstudio/src/org/micromanager/acquisition/OMEMetadata.java:31: error: package ome.units does not exist
 [mm-javac] /opt/mm/micro-manager1.4/mmstudio/src/org/micromanager/acquisition/OMEMetadata.java:32: error: package ome.units.quantity does not exist
 [mm-javac] /opt/mm/micro-manager1.4/mmstudio/src/org/micromanager/acquisition/OMEMetadata.java:33: error: package ome.units.quantity does not exist
 [mm-javac] 3 errors

BUILD FAILED
/opt/mm/micro-manager1.4/buildscripts/javabuild.xml:110: Compile failed; see the compiler error output for details.

Total time: 6 seconds
make[1]: *** [Makefile:891: MMJ_.jar] Error 1
make: *** [Makefile:521: all-recursive] Error 1

 

I am still getting obove mentioned error.

 

What you mean with using https fix the issue?  at this likes?

 

svn co https://valelab4.ucsf.edu/svn/micromanager2/trunk/ micro-manager1.4 svn co https://valelab4.ucsf.edu/svn/3rdpartypublic/

 

Best regards,

Ravi

 

 

-----Ursprüngliche Nachricht-----
Von: "Stuurman Nico" [[hidden email]]
Gesendet: So. 12.05.2019 05:30
An: "Micro-Manager General" [[hidden email]]
Betreff: Re: [micro-manager-general] Building micro-manager on ubuntu 18.04 (and MMbuild on Mac)

Hi all builders,

Thank you, but unfortunately it looks like i still have exactly the same error. I   https://valelab4.ucsf.edu/svn/ but it didn't solve the problem. If it solves it for others then i will clean up everything and re-install everything fresh.

Sorry about that.  Using https rather than http solves this (apparently, ivy does not like redirects).  I tested it and committed in revision 17028, so hopefully, it now really works for you too.  Pushed this through to gamma as well, so if 1.4 or 2.0-gamma does not build, please reply here on the mailing list.  Not sure what this does to 2.0-beta...


Best,

Nico

-----Ursprüngliche Nachricht Ende-----




_______________________________________________
micro-manager-general mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/micro-manager-general
Reply | Threaded
Open this post in threaded view
|

Re: Building micro-manager on ubuntu 18.04 (and MMbuild on Mac)

Stuurman, Nico

On 5/12/2019 7:51 AM, [hidden email] wrote:

>
>     Thank you, but unfortunately it looks like i still have exactly
>     the same error. I https://valelab4.ucsf.edu/svn/
>     <https://valelab4.ucsf.edu/svn/micromanager2/trunk/> but it didn't
>     solve the problem. If it solves it for others then i will clean up
>     everything and re-install everything fresh.
>
>
> Sorry about that.  Using https rather than http solves this
> (apparently, ivy does not like redirects).  I tested it and committed
> in revision 17028, so hopefully, it now really works for you too. 
> Pushed this through to gamma as well, so if 1.4 or 2.0-gamma does not
> build, please reply here on the mailing list.  Not sure what this does
> to 2.0-beta...
>
> -----Ursprüngliche Nachricht Ende-----
>

> I am still getting obove mentioned error.
>

Did you do:

svn up
make fetchdeps

If so, paste the relevant output of make fetchdeps.

>  What you mean with using https fix the issue?  at this likes?
>

Background:

Micro-Manager uses several maven update sites to download the
dependencies for the Java build.  These are downloaded using a tool
called "ivy".  The Imagej maven site was recently moved from
maven.imagej.net to maven.scijava.net. There were redirects in place,
but these did not work, so this move broke the MM build for people who
had not yet downloaded the dependencies in their local cache (one reason
I did not notice the change). The change was also not communicated in a
clear way.  In my first update, I use the http://maven.scijava.net 
address rather than https://maven.scijava.net.  It turned out that only
the latter worked.  Curtis Rueden will try to make sure that the old
address: http://maven.imagej.net will work again, so that older code can
be build again without going through a lot of trouble.

The current code fetches dependencies from scijava.net (at least for
me), so should work, but if you had trouble before, you will surely need
to update your code and run make fetchdeps.  Also, the output of the
compiler is not helpful, the output of ivy is.

Best,

Nico



_______________________________________________
micro-manager-general mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/micro-manager-general
Reply | Threaded
Open this post in threaded view
|

Re: Building micro-manager on ubuntu 18.04 (and MMbuild on Mac)

Aurélien Courtois
Hi Nico,
Thank you a lot !
I updated my version of micro-manager1.4 and then make fetchdeps gave less "not found"
only the last 3 ones:
[ivy:resolve]   :: #ij3d-bin;: not found
[ivy:resolve]   :: #ima3d_;: not found
[ivy:resolve]   :: #DT1.2;: not found

which you said i don't have access to anyway. But the "make" still didn't work, for the same reason as before apparently.
As it looked like it should have worked, I re-installed ubuntu fresh and re-installed micro-manager and this time it worked. So i guess the problem is solved for 1.4 version.
Thank you a lot !
Aurelien

Le lun. 13 mai 2019 à 09:00, Stuurman, Nico <[hidden email]> a écrit :

On 5/12/2019 7:51 AM, [hidden email] wrote:
>
>     Thank you, but unfortunately it looks like i still have exactly
>     the same error. I https://valelab4.ucsf.edu/svn/
>     <https://valelab4.ucsf.edu/svn/micromanager2/trunk/> but it didn't
>     solve the problem. If it solves it for others then i will clean up
>     everything and re-install everything fresh.
>
>
> Sorry about that.  Using https rather than http solves this
> (apparently, ivy does not like redirects).  I tested it and committed
> in revision 17028, so hopefully, it now really works for you too. 
> Pushed this through to gamma as well, so if 1.4 or 2.0-gamma does not
> build, please reply here on the mailing list.  Not sure what this does
> to 2.0-beta...
>
> -----Ursprüngliche Nachricht Ende-----
>

> I am still getting obove mentioned error.
>

Did you do:

svn up
make fetchdeps

If so, paste the relevant output of make fetchdeps.

>  What you mean with using https fix the issue?  at this likes?
>

Background:

Micro-Manager uses several maven update sites to download the
dependencies for the Java build.  These are downloaded using a tool
called "ivy".  The Imagej maven site was recently moved from
maven.imagej.net to maven.scijava.net. There were redirects in place,
but these did not work, so this move broke the MM build for people who
had not yet downloaded the dependencies in their local cache (one reason
I did not notice the change). The change was also not communicated in a
clear way.  In my first update, I use the http://maven.scijava.net
address rather than https://maven.scijava.net.  It turned out that only
the latter worked.  Curtis Rueden will try to make sure that the old
address: http://maven.imagej.net will work again, so that older code can
be build again without going through a lot of trouble.

The current code fetches dependencies from scijava.net (at least for
me), so should work, but if you had trouble before, you will surely need
to update your code and run make fetchdeps.  Also, the output of the
compiler is not helpful, the output of ivy is.

Best,

Nico



_______________________________________________
micro-manager-general mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/micro-manager-general



_______________________________________________
micro-manager-general mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/micro-manager-general