error messages

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

error messages

Knecht, David
I changed my lab class microscopes over to Windows 10 with Lumenara cameras this spring and generally things are working.  We are getting periodic capture failures at seemingly random times on each of the microscope workstations (all are set up identically initially).  I am hoping someone can make suggestions as to how to minimize or eliminate these acquisition failures as they are cropping up infrequently, but in a 1000 frame acquisition, we frequently do not get through the entire time sequence.   There are three types of errors:

Java errors: These show up in an error log file in the MM folder with a long file that starts:

A fatal error has been detected by the Java Runtime Environment:
#
#  EXCEPTION_ACCESS_VIOLATION (0xc0000005) at pc=0x0000000010caea36, pid=2368, tid=5636
#
# JRE version: 6.0_31-b05
# Java VM: Java HotSpot(TM) 64-Bit Server VM (20.6-b01 mixed mode windows-amd64 compressed oops)
# Problematic frame:
# C  0x0000000010caea36

Lucam camera errors: these pop up on screen in MM, but do not show up in error logs

Error: Acquisition Failed
Device Failure: Lucam

and something that seems a hybrid in that it is a Lucam error that pops up on screen  with no log and a different message:

java.land Exception    Error in device “Lucam”  Unknown error in the device (1)


Dr. David Knecht
Professor, Department of Molecular and Cell Biology 
University of Connecticut
91 N. Eagleville Rd.
U-3125
Storrs, CT 06269-3125
860-486-2200



_______________________________________________
micro-manager-general mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/micro-manager-general
Reply | Threaded
Open this post in threaded view
|

Re: error messages

Nico Stuurman-2
Hi David,

> I changed my lab class microscopes over to Windows 10 with Lumenara
> cameras this spring and generally things are working.  We are getting
> periodic capture failures at seemingly random times on each of the
> microscope workstations (all are set up identically initially).  I am
> hoping someone can make suggestions as to how to minimize or eliminate
> these acquisition failures as they are cropping up infrequently, but
> in a 1000 frame acquisition, we frequently do not get through the
> entire time sequence.   There are three types of errors:

All three errors point back to the Lumenera part of the code.  Since the
Lumenera code is not OPen Source and not in the Micro-Manaeger
repository, there is nothing anyone outside of Lumenera can do about
this.  Apparently, Lumenera has become part of Teledyne, and maybe they
are interested in changing their policies so that we can have more eyes
on the code, and hopefully others can start helping out? However, even
then, it would be most helpful if Lumenera engineers can look into this
problem.

Best,


Nico



_______________________________________________
micro-manager-general mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/micro-manager-general