Quantcast

failed to initialize circular buffer

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

failed to initialize circular buffer

aomf

We need Micro Manager to control the ASI light sheet microscope. We installed micro manager onto a brand new DELL Precision Tower 7810 computer. It has Nvidia Quadro M2000 4GB video card, 128 GB RAM. Run by Windows 7 64bit. Windows can recognize the 128 GB RAM. When I start micro manager, I always receive an error message "failed to initialize circular buffer - memory requirements not adequate". Whatever the size I put under Image J\Edit\Options\Memory & threads, and Micro Manager\Tools\Options\Sequence buffer size, this error message always shows up. I have tried different version of Micro Manager from 1.4 to 2.0 beta, and many 2.0 beta 3 versions but could not correct this error. Please help! Thank you!

 

Feng


------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, SlashDot.org! http://sdm.link/slashdot
_______________________________________________
micro-manager-general mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/micro-manager-general
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: failed to initialize circular buffer

JonD
aomf wrote
We need Micro Manager to control the ASI light sheet microscope. We installed micro manager onto a brand new DELL Precision Tower 7810 computer. It has Nvidia Quadro M2000 4GB video card, 128 GB RAM. Run by Windows 7 64bit. Windows can recognize the 128 GB RAM. When I start micro manager, I always receive an error message "failed to initialize circular buffer - memory requirements not adequate". Whatever the size I put under Image J\Edit\Options\Memory & threads, and Micro Manager\Tools\Options\Sequence buffer size, this error message always shows up. I have tried different version of Micro Manager from 1.4 to 2.0 beta, and many 2.0 beta 3 versions but could not correct this error. Please help! Thank you!
aomf wrote
I just found out how to solve the problem. To solve this problem I have to set the memory size before setting up the hardware configuration. The problem I have in my previous post was caused because I load the same hardware setting after I reset the memory size.  Thanks.
Hi Feng,

That is a bit odd, I'm glad you found a work-around.  My guess was going to be that you were using Multi Camera without setting the Physical Camera properties; I've often seen error messages that are not descriptive/accurate when those aren't set correctly.

For the ASI diSPIM plugin [1], I highly suggest using a recent nightly build of 1.4.x [2] instead of the latest official release (now quite old) or 2.0 beta.

Jon

[1] https://micro-manager.org/wiki/ASIdiSPIM_Plugin
[2] https://micro-manager.org/wiki/Micro-Manager_Nightly_Builds

-------------------------------------------
Jon Daniels
Applied Scientific Instrumentation
29391 West Enid Rd, Eugene, OR 97402
Phone: (541) 461-8181 x118
-------------------------------------------
Loading...