point grey cameras don't show up

classic Classic list List threaded Threaded
6 messages Options
Reply | Threaded
Open this post in threaded view
|

point grey cameras don't show up

Avi.Ring

..in hardware configuration wizard for camera devices.

 

Windows 7, Flycapture 2.10.3.266 SDK, moved DLL’s to the default µ-M directory.

My camera is the colour version: Chameleon3 CM3-U3-31S4C

and it works well with the Point Grey Demo and (with the SDK) from MS Visual Studio 2017.

 

Tried unplugging camera / save new config/ restart PC etc, I get no Point Grey cameras at all as options.

The Flycapture2-v100.DLL was only in the BIN folder, the lib…DLL  required was in BIN64. Could that be a problem for seeing the camera list?

Grateful for any suggestions.

(micro-manager newbie).

Avi

 

 

 

 

 

 


------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, Slashdot.org! http://sdm.link/slashdot
_______________________________________________
micro-manager-general mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/micro-manager-general
Reply | Threaded
Open this post in threaded view
|

Re: point grey cameras don't show up

Nico Stuurman-2


On 1/17/18 2:02 PM, [hidden email] wrote:
> 1. Yes I'm on 64 bit WIn7
>
> 2. Downloaded 32 & 64 bit µM and 32 & 64bit Flycapture 2.10.3.266 .... on another HP laptop (also 64 bit Win7).
>
> 3. Tried 64 bit µM with 32 & 64 Flycapture, the 32 bit µM w 32 Flycapture.  I did remember to delete the two DLLs in between installations. libiomp5md.dll and FlyCapture2_v100.dll.

Just stick to the 64 bit versions of everything.  Don't complicate
things with unnecessary 32-bit versions.
> 4. Nothing worked, it doesn't show up (I kept the camera plugged in)
>
> 5. I checked the CorLogs ; no, point grey doesn't show up there

???  It should at least be listed.  Which Micro-manager version are you
using?

Best,

Nico


------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, Slashdot.org! http://sdm.link/slashdot
_______________________________________________
micro-manager-general mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/micro-manager-general
Reply | Threaded
Open this post in threaded view
|

Re: point grey cameras don't show up

Avi.Ring
1.4.22 for both the 32 & 64 bit
off to bed soon, 00:15 now.
Appreciate your help
Avi

________________________________________
From: Nico Stuurman [[hidden email]]
Sent: Wednesday, January 17, 2018 23:37
To: Micro-Manager General
Subject: Re: [micro-manager-general] point grey cameras don't show up

On 1/17/18 2:02 PM, [hidden email] wrote:
> 1. Yes I'm on 64 bit WIn7
>
> 2. Downloaded 32 & 64 bit µM and 32 & 64bit Flycapture 2.10.3.266 .... on another HP laptop (also 64 bit Win7).
>
> 3. Tried 64 bit µM with 32 & 64 Flycapture, the 32 bit µM w 32 Flycapture.  I did remember to delete the two DLLs in between installations. libiomp5md.dll and FlyCapture2_v100.dll.

Just stick to the 64 bit versions of everything.  Don't complicate
things with unnecessary 32-bit versions.
> 4. Nothing worked, it doesn't show up (I kept the camera plugged in)
>
> 5. I checked the CorLogs ; no, point grey doesn't show up there

???  It should at least be listed.  Which Micro-manager version are you
using?

Best,

Nico


------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, Slashdot.org! http://sdm.link/slashdot
_______________________________________________
micro-manager-general mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/micro-manager-general

------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, Slashdot.org! http://sdm.link/slashdot
_______________________________________________
micro-manager-general mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/micro-manager-general
Reply | Threaded
Open this post in threaded view
|

Re: point grey cameras don't show up

Nico Stuurman-2


On 1/17/18 3:17 PM, [hidden email] wrote:
> 1.4.22 for both the 32 & 64 bit

Ah.  There you go.  Use the latest nightly build instead.  The Point
Grey adapter was added after the 1.4.22 release.

Best,

Nico


------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, Slashdot.org! http://sdm.link/slashdot
_______________________________________________
micro-manager-general mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/micro-manager-general
Reply | Threaded
Open this post in threaded view
|

Re: point grey cameras don't show up

Avi.Ring
Point Grey Chameleon3 colour camera now working in µ-manager (monchrome mode).
(In relation to other query in this forum: only bin mode 1 shows up).
Thank you for the feedback,
Avi

________________________________________
From: Nico Stuurman [[hidden email]]
Sent: Thursday, January 18, 2018 00:36
To: Micro-Manager General
Subject: Re: [micro-manager-general] point grey cameras don't show up

On 1/17/18 3:17 PM, [hidden email] wrote:
> 1.4.22 for both the 32 & 64 bit

Ah.  There you go.  Use the latest nightly build instead.  The Point
Grey adapter was added after the 1.4.22 release.

Best,

Nico


------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, Slashdot.org! http://sdm.link/slashdot
_______________________________________________
micro-manager-general mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/micro-manager-general

------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, Slashdot.org! http://sdm.link/slashdot
_______________________________________________
micro-manager-general mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/micro-manager-general
Reply | Threaded
Open this post in threaded view
|

Re: point grey cameras don't show up

Nico Stuurman-2
>
>> On 1/17/18 3:17 PM, [hidden email] wrote:
>>> 1.4.22 for both the 32 & 64 bit
>> Ah.  There you go.  Use the latest nightly build instead.  The Point
>> Grey adapter was added after the 1.4.22 release.
>
> Point Grey Chameleon3 colour camera now working in µ-manager (monchrome mode).
> (In relation to other query in this forum: only bin mode 1 shows up).

Did you check the Device/Property browser?  There may be a "PixelType"
property that you can set to RGB or something similar.

Best,

Nico



------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, Slashdot.org! http://sdm.link/slashdot
_______________________________________________
micro-manager-general mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/micro-manager-general